General developer forum

Require.js Error on Participants and Editing Activity pages

 
Picture of Robert Payne
Require.js Error on Participants and Editing Activity pages
 

Hello,

We've suddenly started getting require.js errors on our moodle site when either editing activities or viewing the participants page for a course (on the participants page it actually pops up twice).

The message says:

Mismatched anonymous define() module: function(){return g} http://requirejs.org/docs/errors.html#mismatch

I've also attached a picture of the message.


I can't work out why this is occurring as we haven't changed anything with our plugins for over a month so I'm not sure what triggered it.


Tried these pages with different themes and still occurs so I think themes aren't to blame.


Any one have any idea what would be causing this? I've looked at other posts mentioning this from previous years but they seem to be related to specific plugins we don't use.


We're currently on Moodle 3.4.3


Cheers,
Rob

 
Average of ratings: -
Picture of Robert Payne
Re: Require.js Error on Participants and Editing Activity pages
 

UPDATE:
It seems to be related to the dock, the error stops displaying when I move all blocks out of the dock.
Maybe it is a theme issue as both themes I tested with so far were using the dock?


UPDATE2:

Actually the error still appears when nothing is docked on these pages if I make sure course editing is turned off :/ 
Oddly specific :/

 
Average of ratings: -
Picture of Robert Payne
Re: Require.js Error on Participants and Editing Activity pages
 

Solution found, kinda.

A local analytics tool was causing the issue. Disabled it for now.

 
Average of ratings: -