General help

Undefined boxes in Moodle 3.5!

 
Picture of Hugh Macdonald
Re: Undefined boxes in Moodle 3.5!
 

Ken,

Debugging is on, but the only thing I can find in the logs is:


myipaddress mydomain.net - [14/Jun/2018:22:41:26 +0200] "POST /lib/ajax/service.php?sesskey=ea4PlD5Hph&info=message_popup_get_unread_popup_notification_count HTTP/1.1" 403 229 "https://mydomain.net/admin/plugins.php?updatesonly=0&contribonly=1" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0"
myipaddress mydomain.net - [14/Jun/2018:22:41:26 +0200] "POST /lib/ajax/service.php?sesskey=ea4PlD5Hph&info=core_fetch_notifications HTTP/1.1" 403 229 "https://mydomain.net/admin/plugins.php?updatesonly=0&contribonly=1" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0"

Would updating the database to the Barracuda format and to the updated UTF-8 format help with this?

Best wishes,

Hugh

 
Average of ratings: -
Picture of Ken Task
Re: Undefined boxes in Moodle 3.5!
Particularly helpful Moodlers

Did you fix DB issues?   May as well do it now.   But don't think those DB issues relate to 403 errors.

The 403 in logs indicate 'access denied'.   Check ownerships/permissions on all folders/files in code and on a folders/files in moodledata.

Code .... readable by all but writable only by owner group readable should be ok - that owner is the web service user.

Data  directory .... needs it all.

'spirit of sharing', Ken


 
Average of ratings: -
Picture of Hugh Macdonald
Re: Undefined boxes in Moodle 3.5!
 

Ken,

Thanks very much for your help.

I was able to create a Private SQL server as part of my shared hosting package with OVH, and chose MariaDB 10.2.

Seemingly this uses the Barracuda format by default, as the error is no longer there and running the first php script showed nothing needed changing.

I was able to change the uft format with the other command. In order to do it I had to optimise the mdl_logstore_standard_log table.

I also tried changing all permissions for moodle and moodledata to 705 / 604.

I also stopped showing the Notifications icon in /admin/message.php.

One of these things has stopped the Undefined popups nag, but I am not sure which. I think it may actually have been the utf format change and logstore optimisation!?

Best wishes,

Hugh

 
Average of ratings: -