General developer forum

Problems running grunt/cibit precheck

 
Picture of Baptiste Desprez
Re: Problems running grunt/cibit precheck
Plugin developers

Hi Michael,

I had the same problem. It's because of :

    public static function get_reason() : string {
        return 'privacy:metadata';
    }

in provider.php, which is only compatible with PHP 7 (Moodle >= 3.4)

You have to make a specific version for Moodle < 3.4.

You can see the small change to make in https://github.com/moodle/moodle/blob/MOODLE_33_STABLE/enrol/guest/classes/privacy/provider.php

 
Average of ratings: Useful (2)