Installing and upgrading help

Moodle 3.1 and php 7.1 risks ?

 
Picture of Paul L
Moodle 3.1 and php 7.1 risks ?
 

I recently upgraded php and moodle at the same time on our development site, from php 5.6->7.1 and then moodle 3.1.5+->3.3.5+

After upgrading php moodle server notice stated 7.1 was not supported for moodle 3.1. The site still worked and I proceeded to immediately upgrade moodle from 3.1 to 3.3 but I was wondering if there are any risks or downsides to briefly operating moodle 3.1 with php 7.1 in maintenance mode?

I was thinking about re-trying the whole upgrade process in our development site only this time upgrading moodle first and then php.

 
Average of ratings: -
Picture of Paul L
Re: Moodle 3.1 and php 7.1 risks ?
 

I just did a little research on the differences between 7.0 and 7,1, for the most part it was not major syntax/feature changes but the focus on backend performance so I guess that's why I noticed no issues.

 
Average of ratings: -
Picture of Howard Miller
Re: Moodle 3.1 and php 7.1 risks ?
Core developersDocumentation writersParticularly helpful MoodlersPlugin developers

Moodle 7.1 is not supported for Moodle 3.1. If the release notes say it's not supported then you can be *sure* that there are problems. 

There were a whole bunch of problems reported in the tracker, see MDL-55120

 
Average of ratings: -
Picture of Paul L
Re: Moodle 3.1 and php 7.1 risks ?
 

Thanks for the info Howard, I will be sure to upgrade moodle from 3.1 to 3.3 before upgrading php from 5.6 to 7.1

 
Average of ratings: -