Assistance technique

Mauvais test avant MAJ de Moodle

 
Avatar Valery Fremaux
Re: Mauvais test avant MAJ de Moodle
Développeurs de pluginsMoodleurs particulièrement utiles

Non daniel, ce n'est pas autre chose :

dans certains environnements, mariaDB est vu comme un ... MySQL (tiens donc)...

le fichier qui gère les exigences de moodle sur l'environnement est :

/admin/environment.xml

Il y a une section par version

selon ton environnement d'exécution, cette identification se trompe et tape dans la ligne de version pour MySQL. Ce n'est pas nouveau d'ailleurs, je traine ça depuis 2.7...

Une solution rapide est de modifier la ligne relative au MySQL et mettre ta version 5.5.5 dedans.

Cette déclaration n'est souvent que formelle. L'incompatibilité est parfois toute théorique (mais parfois pas ! va essayer de tourner un moodle 3.5 en php 5.6 et tu verras... clin d’œil )

 
Moyenne des évaluations  -
C'est moi :-)
Re: Mauvais test avant MAJ de Moodle
Documentation writersMoodleurs particulièrement utilesTesteursTraducteurs

Bonjour,

C'est a priori effectivement lié à MariaDB.

Par contre, non : 5 < 31 !

La réponse courte et solution simple : dans le fichier de configuration config.php, il faut spécifier (si on utilise MariaDB) :

$CFG->dbtype = 'mariadb';

En espérant que cela aide...

Séverin

 
Moyenne des évaluations Utile (2)
Avatar Valery Fremaux
Re: Mauvais test avant MAJ de Moodle
Développeurs de pluginsMoodleurs particulièrement utiles

en effet... ca m'actualise clin d’œil

 
Moyenne des évaluations  -