Installing and upgrading help

Error when upgrading to 3.4