Assistance technique

Problème de lecture de la base de donnée

 
C'est moi :-)
Re: Problème de lecture de la base de donnée
Documentation writersMoodleurs particulièrement utilesTesteursTraducteurs

Passer de Moodle 3.1.5 à 3.1.11 est une mise à jour mineure (restant dans la même branche majeure), tu peux donc simplement copier les fichiers constituant Moodle 3.1.11 par dessus ceux de Moodle 3.1.5 et lancer la mise à jour.

 
Moyenne des évaluations  -
Avatar Cyril Brändli
Re: Problème de lecture de la base de donnée
 

Bonjour Séverin,

La copie du contenu de la version 3.1.11 se fait simplement avec FileZilla dans le répertoire /Moodle en remplaçant les fichiers existants?

En ce qui concerne la base de donnée MySQL, faut-il en créer une nouvelle avant de lancer le scrypte install.php?; je pense que oui puisque le problème concerne la lecture de celle-ci et j'espère ne rien perdre des cours/utilisateurs/annonces etc.. de la base actuelle.

L'hébergeur fait quotidiennement une copie complète de notre espace, j'en conclu qu'en cas de problème, je peux voir avec lui pour tout recharger?

Mes questions sont un peu triviales car je n'ai jamais fait ce genre d'action.

Merci encore pour ton aide

Bonne soirée

 
Moyenne des évaluations  -
C'est moi :-)
Re: Problème de lecture de la base de donnée
Documentation writersMoodleurs particulièrement utilesTesteursTraducteurs

Bonjour,

Si l'hébergeur fait une sauvegarde complète du Moodle (dossier Moodle + dossier de données "moodledata" + base de données associée), alors oui, il devrait pouvoir te restaurer la plateforme dans un état précédent.

Pour la mise à jour, oui, il suffit de remplacer les fichiers qui constituent Moodle !

Il n'est pas nécessaire de créer une nouvelle base de données. Si tu le faisais, tu repartirais sur un Moodle vide (et il faudrait également vider le dossier de données "moodledata").

De ce que je comprends de ton message initial, c'est uniquement la partie "Enregistrement de la plateforme" qui pose problème ? Si c'est le cas, tu peux simplement désactiver cette tâche planifiée clin d’œil

Séverin

 
Moyenne des évaluations  -
Avatar Cyril Brändli
Re: Problème de lecture de la base de donnée
 

Bonjour Séverin,

J'ai trouvé dans la doc la façon de faire l'upgrade https://docs.moodle.org/31/en/Upgrading qui déconseille la copie pa dessus...

J'ai créé une copie de sécurité de moodle et repris le config.php file et ensuite, j'ai exécuté la procédure d'upgrade install.php

Il semble que tout ce soit bien passé:

Le principal problème est résolu: envoi des mails lors d'une nouvelle annonce

L'enregistrement dans moodle.net ne marche toujours pas et je peux vivre avec

Attaché: pour info les différentes étapes

Merci d'avance pour  vos remarques

Merci




 
Moyenne des évaluations  -
Avatar Cyril Brändli
Re: Problème de lecture de la base de donnée
 

Bonjour Séverin,

Maintenant, je suis à la version 3.1.12 et il semble que tout fonctionne très bien.

Avec votre information sur les nouvelles versions, je pense passer à 3.4.3

Est-ce le bon choix?

Encore merci pour votre aide



 
Moyenne des évaluations  -
C'est moi :-)
Re: Problème de lecture de la base de donnée
Documentation writersMoodleurs particulièrement utilesTesteursTraducteurs

Bonjour Cyril,

Ça peut être un bon choix, mais pourquoi pas Moodle 3.5, tout juste sorti (que je n'ai pas encore annoncé officiellement de façon détaillée), si votre hébergement le permet ?

Séverin

 
Moyenne des évaluations  -