Cosas de Administradores

Problema con html adicional

 
Imagen de Ricardo Fandiño
Problema con html adicional
 

Buenas noches a todos:

Soy novato en esto y estoy poniendo en marcha moodle para apoyo de unas clases que doy.

Utilizo la versión de moodle 3.4.2.

Esta mañana introduje un código html en el bloque de html adicional. Era un código para que los iframe de las páginas se adaptasen al tamaño de la pantalla.

El problema es que introduje el código en el apartdo Head, en vez de Body.

El resultado es que ahora veo la pantalla en blanco.

Haga lo que haga no puedo loguear ni nada.

He hecho respaldo que hace mi proveedor de hosting de modo automático de hace unos días. y no soluciona el problema.

He intentado de todo ya.

Tras mucho probar, he llegado al a conclusión de que la única solución sería encontrar ese código en el archivo, pero desconozco cual es, y ya llevo mirado unos cuantos, el header, el config.. y la lista es muy larga.


Os agradecería de corazón si a alguien se le ocurre alguna solución, ¿o por el contrario debo  asumir que el trabajo de un mes lo he tirado por la borda?.

Gracias.



 
Promedio de calificaciones: -
Imagen de Sergio Comerón Sánchez-Paniagua
Re: Problema con html adicional
 

Hola Ricardo, 

has probado a ver si puedes llegar a esta dirección http://www.tusitio.com/admin/settings.php?section=additionalhtml ?

prueba a ver si te llega a pintar algo y puedes quitar el head, no creo ya que si lo pusiste en el head sadrá para todo el sitio. Si ves que no puedes tendrás que tocarlo por base de datos, tendrás que tocar la tabla mdl_config y ahí buscar additionalhtmlhead y hacerle un update quitando lo que has metido.


Prueba y nos dices.

 
Promedio de calificaciones:Útil (1)
Imagen de Ricardo Fandiño
Re: Problema con html adicional
 

Hola Sergio, gracias por tu respuesta.

Si había probado con acceder al enlace que tu dices pero no me dejaba, el iframe al estar en el head se ampliaba y no deja acceder a otro contenido.

La verdad que me has dado una idea para el futuro, ni se me había ocurrido ver la base de datos y la tabla mdl_config.... seguramente ahí estaría la solución, y es bueno saberlo.

El caso es que le hablé del problema a  mi proveedor de hosting y le debí dar tanta pena que me lo arregló, no sé como lo hizo, pero lo hizo.

Agradezco de todos modos tu solución. 

 
Promedio de calificaciones: -
Imagen de Sergio Comerón Sánchez-Paniagua
Re: Problema con html adicional
 

Nada! el caso es que se solucionara sonrisa

Cualquier cosa, ya sabes, escribe por el foro que siempre habrá alguien que te ayude. 

 
Promedio de calificaciones: -