General developer forum

Upgrade to 3.3 and Error reading from database

Picture of Ken Task
Re: Upgrade to 3.3 and Error reading from database
Particularly helpful Moodlers

Not a Windows person, but ... the following is true of any platform ...

Are you attempting to upgrade from 2.6.x straight to 3.1.highest?  Note the .highest there.

No can do.   Must upgrade the 2.6.x to 2.7.highest first.

One of the changes for you is related to theme ... many themes, like the 'afterburner' theme you used in the 2.6 doesn't have a compat version in series 3.x.

Once you get the site upgraded to the 2.7.highest, check it for functionality ... especially any plugins ... get those upgraded and working as well.

Then *backup* the code + do a DB dump.  Don't want to loose ground gained at the 2.7.highest stage.

Then try the upgrade to the 3.1.*highest*.

One cannot hyperjump upwards ... it's more a 'march'.

'spirit of sharing', Ken

Average of ratings: -
Picture of katherine tk
Re: Upgrade to 3.3 and Error reading from database

Hello Ken Task,

Thanks for the suggestion. But unfortunate I came through the same error even after 2.7.

Error Loading Database

add_to_log() has been deprecated,please rewrite your code to the new events API

 .line 50 of\lib\deprecatedlib.php: call to debugging()

 . line 133 of\index.php: call to add_to_log()

error reading from database

Debug info:SQLState:42S22<br>

Error Code: 207<br>

Message:[Microsoft][ODBC Driver 11 for SQL Server]Invaild coloumn name 'requiredbytheme'.<br>



Message: [Microsoft][ODBC Driver 11 for SQL Server][SQL Server]Invalid coloumn name 'requiredbytheme'.

Average of ratings: -
Picture of Ken Task
Re: Upgrade to 3.3 and Error reading from database
Particularly helpful Moodlers

Like I said ... don't run Windows ... but ... 2.6 to 2.7 won't do and the errors you show might indicate you've already upgraded the PHP to a higher version in anticipation of being able to hyperjump.   When it comes  to upgrading from an old to highest, all platforms are in the same boat.   You can't pull the trigger on upgrading PHP until you are sure  the version you have can run the upgrade to the version you are moving to.   That make sense?

Here's why I think the above ...

add_to_log() has been deprecated

So you might have to down grade your PHP so that the uprade to 2.7 will work.

PHP 5.4.x or 5.5.x on Windows.

So let's say that works and you do get to 2.7.highest.

Rather than searching the web and a lot of scratching of heads.

Go to Site Admin -> Server -> Environment.

Update the component

Then use the drop down pick list for moodle version and see what Moodle says you'll need ... for php version, for php extensions, for DB config, etc..   You should be able to map out a plan then.

@Tunde ... seldom does one have *exactly* the same problem ... *same exact error* ... but yours might be *similar* to Katherine's.   Anyhoo the same advice ... use the Environment check on existing version to see what you need moving forward from an old version to map out when to upgrade PHP, etc..

'spirit of sharing', Ken

Average of ratings: -