General developer forum

Unable to run grunt

 
Picture of Howard Miller
Unable to run grunt
Core developersDocumentation writersParticularly helpful MoodlersPlugin developers

I'm trying to run grunt for a custom development on Moodle 3.3. I'm a bit stuck

nodejs is a bit of mystery to me which doesn't help.

When I try to run 'grunt' I get this error...

Fatal error: Node version too old. Require >=8.9.0 <8.10.0, version installed: 8.11.1

which is both incorrect and unhelpful. Any thoughts?

 
Average of ratings: -
Picture of Matteo Scaramuccia
Re: Unable to run grunt
Core developersParticularly helpful MoodlersPlugin developers

Hi Howard,
you should stick with the LTS version of node supported by Moodle i.e. 8.9 (maintained up to Apr 2019): MDL-60503.

You can find it in https://nodejs.org/download/release/v8.9.4/ : it worth noting that you could file an issue into the Tracker to take care of bumping the 8.x LTS version to the latest available, at least in 3.5 (my +1 for 3.4 too).

HTH,
Matteo

 
Average of ratings: Useful (1)
Picture of Howard Miller
Re: Unable to run grunt
Core developersDocumentation writersParticularly helpful MoodlersPlugin developers

Thanks!

I might be being a bit dim... but I downloaded and expanded the file and now what do I do with it? There's no installation instructions that I can find.

 
Average of ratings: -
Picture of Howard Miller
Re: Unable to run grunt
Core developersDocumentation writersParticularly helpful MoodlersPlugin developers

For those as dim as me, I found some likely looking instructions (well Google did)...

https://github.com/nodejs/help/wiki/Installation

node seems to work, but not npm. Still investigating.

One of the less user friendly bits of software I have encountered... 

EDIT

Sorted... actually reading the instructions properly helps. Works as advertised. 

I don't really feel qualified to put in a tracker report. I just use this stuff mindlessly.I should probably have a proper look. Add it to "the list"

 
Average of ratings: Useful (2)
Picture of Matteo Scaramuccia
Re: Unable to run grunt
Core developersParticularly helpful MoodlersPlugin developers

Hi Howard,
glad you sorted it out!

FYI: MDL-61893

HTH,
Matteo

 
Average of ratings: Useful (1)
Picture of Howard Miller
Re: Unable to run grunt
Core developersDocumentation writersParticularly helpful MoodlersPlugin developers

You know those days when EVERYTHING refuses to work? big grin

 
Average of ratings: -