I'm trying to run grunt for a custom development on Moodle 3.3. I'm a bit stuck
nodejs is a bit of mystery to me which doesn't help.
When I try to run 'grunt' I get this error...
Fatal error: Node version too old. Require >=8.9.0 <8.10.0, version installed: 8.11.1
which is both incorrect and unhelpful. Any thoughts?
You can find it in https://nodejs.org/download/release/v8.9.4/ : it worth noting that you could file an issue into the Tracker to take care of bumping the 8.x LTS version to the latest available, at least in 3.5 (my +1 for 3.4 too).
For those as dim as me, I found some likely looking instructions (well Google did)...
node seems to work, but not npm. Still investigating.
One of the less user friendly bits of software I have encountered...
Sorted... actually reading the instructions properly helps. Works as advertised.
I don't really feel qualified to put in a tracker report. I just use this stuff mindlessly.I should probably have a proper look. Add it to "the list"