General developer forum

Upgrade to Moodle version 3.4.1 ERRORS

 
Picture of Francesca ashley cooper
Upgrade to Moodle version 3.4.1 ERRORS
 

I ran a upgrade of the moodle files to 3.4.1, but I am getting the following errors.

I have confirmed with the hosts that the tables are using Barracuda.

And I changed the unicode to utf8mb4 But I still get these errors.

I am desperate for any help that you can give!

InformationReportPluginStatus
unsupported_db_table_row_format

Your database has tables using Antelope as the file format. You are recommended to convert the tables to the Barracuda file format. See the documentation Administration via command line for details of a tool for converting InnoDB tables to Barracuda.

Check
mysql_full_unicode_support

The current setup of MySQL or MariaDB is using 'utf8'. This character set does not support four byte characters which include some emoji. Trying to use these characters will result in an error when updating a record, and any information being sent to the database will be lost. Please consider changing your settings to 'utf8mb4'. See the documentation for full details.


 
Average of ratings: -
Picture of Francesca ashley cooper
Re: Upgrade to Moodle version 3.4.1 ERRORS
 

Problem solves - it was that MySQL is not of the required version.

 
Average of ratings: -