Dataform (plugin)

Dataform compatible with Moodle 3.4 ?

 
Picture of Francis Vendrell
Dataform compatible with Moodle 3.4 ?
 

Hello,

I would like to know if somebody has tested the last dataform version (3.3.2) with Moodle 3.4 ?

Are they compatible ?

Thanks in advance


 
Average of ratings: -
Picture of Van Romine
Re: Dataform compatible with Moodle 3.4 ?
 

I have been successfully using dataforms in Moodle 3.4.4 for several weeks.... I just upgraded to 3.5.1. No errors. My configuration is:

  • Moodle 3.5.1
  • PHP 7.2.9 (with mcrypt added through PECL) 

https://lukasmestan.com/install-mcrypt-extension-in-php7-2/


HTH


 
Average of ratings: -
Picture of Francis Vendrell
Re: Dataform compatible with Moodle 3.4 ?
 

Thank you Van Romine for your answer!

smile

 
Average of ratings: -
Picture of Greg Rudl
Re: Dataform compatible with Moodle 3.4 ?
 

I created a new moodle instance (vers 3.5)with Bitnami Launchpad for AWS Cloud and I can't create a new entry nor edit an existing one.

 
Average of ratings: -
Picture of Van Romine
Re: Dataform compatible with Moodle 3.4 ?
 

I have done both:

  • Created an Ubuntu 18.04 server instance from scratch, installed Moodle 3.5 and dataforms.
  • Downloaded Bitnami LAMP stack (Ubuntu 18.04 and PHP 7.29) Moodle and then added Moodle 3.5 and dataforms

Can you check a few things?

  • What do your syslogs say when you add an entry for a dataform?
  • Turn on full Moodle debugging and what does it say?

I need more information in order to recommend a next step.

 
Average of ratings: -
Picture of Greg Rudl
Re: Dataform compatible with Moodle 3.4 ?
 

Not sure what to make of this:


Warning: Parameter 1 to dataformfield_time_renderer::display_edit() expected to be a reference, value given in /opt/bitnami/apps/moodle/htdocs/mod/dataform/classes/pluginbase/entriesform.php on line 68

Warning: Parameter 1 to dataformfield_selectmulti_renderer::display_edit() expected to be a reference, value given in /opt/bitnami/apps/moodle/htdocs/mod/dataform/classes/pluginbase/entriesform.php on line 68

Warning: Parameter 1 to dataformfield_selectmulti_renderer::display_edit() expected to be a reference, value given in /opt/bitnami/apps/moodle/htdocs/mod/dataform/classes/pluginbase/entriesform.php on line 68

Warning: Parameter 1 to dataformfield_selectmulti_renderer::display_edit() expected to be a reference, value given in /opt/bitnami/apps/moodle/htdocs/mod/dataform/classes/pluginbase/entriesform.php on line 68

Warning: Parameter 1 to dataformfield_textarea_renderer::display_edit() expected to be a reference, value given in /opt/bitnami/apps/moodle/htdocs/mod/dataform/classes/pluginbase/entriesform.php on line 68

Warning: Parameter 1 to dataformfield_text_renderer::display_edit() expected to be a reference, value given in /opt/bitnami/apps/moodle/htdocs/mod/dataform/classes/pluginbase/entriesform.php on line 68

 
Average of ratings: -
Picture of Van Romine
Re: Dataform compatible with Moodle 3.4 ?
 

I've seen PHP be very picky like this. What version of PHP are you using? 7.0 is most highly recommended, 7.2 is also stable. However, 7.1 was a little harder to make work with Moodle.... (my experience)... your mileage may vary.

 
Average of ratings: -
Picture of Greg Rudl
Re: Dataform compatible with Moodle 3.4 ?
 

PHP Version 7.0.31


 
Average of ratings: -
Picture of Van Romine
Re: Dataform compatible with Moodle 3.4 ?
 

I would suggest you reinstall Moodle using the bitnami module... see below:


DO YOU ALREADY HAVE WAMP / MAMP / LAMP INSTALLED?

If you already have WAMP, MAMP or LAMP installed, you can add Bitnami Moodle Stack on top of that installation using a module:


 
Average of ratings: -
Picture of Greg Rudl
Re: Dataform compatible with Moodle 3.4 ?
 

I installed Moodle on my PC (as you described) and was able to use DF. But after restoring a DF from Moodle 3.2 site into this new instance the result was that some of the fields were crowded--see SS attached. I have what I need--thanks for your help.


 
Average of ratings: -