Installing and upgrading help

Scheduled task failed: Forum mailings and maintenance jobs

 
Trang - deserted
Scheduled task failed: Forum mailings and maintenance jobs
 

We've just upgraded to Moodle 3.4.1+ (Build: 20180208) and I noticed the forum digests hadn't gone out tonight. I've looked at Scheduled Tasks and noticed many of the jobs are showing as never having run. Running some of them manually produces this error:

Execute scheduled task: Forum mailings and maintenance jobs (mod_forum\task\cron_task)
... started 22:15:28. Current memory use 31.6MB.
... used 3 dbqueries
... used 0.015706062316895 seconds
Scheduled task failed: Forum mailings and maintenance jobs (mod_forum\task\cron_task),Coding error detected, it must be fixed by a programmer: Function cron_setup_user() cannot be used in normal requests!
The cron output is as follows; I normally get a bigger list than this. Is this a Moodle side error or a hosting problem please? Thanks


Server Time: Tue, 13 Feb 2018 22:20:01 +0000


Execute scheduled task: Legacy cron processing for plugins (core\task\legacy_plugin_cron_task)
... started 22:20:01. Current memory use 14.3MB.
Running auth crons if required...
Running cron for auth/mnet...
Running enrol crons if required...
Running cron for enrol_manual...
Verifying manual enrolment expiration...
...manual enrolment updates finished.
manual enrolment expiry notifications were already sent today at Tuesday, 13 February 2018, 6:13 AM.
Starting activity modules
Processing module function assign_cron ...
... used 4 dbqueries
... used 2.8917720317841 seconds
done.

 
Average of ratings: -
Picture of Howard Miller
Re: Scheduled task failed: Forum mailings and maintenance jobs
Core developersDocumentation writersParticularly helpful MoodlersPlugin developers

The first bit is explained by... MDL-60514

 
Average of ratings: Useful (1)
Trang - deserted
Re: Scheduled task failed: Forum mailings and maintenance jobs
 

Thanks Howard

I've got into the table mdl_task_scheduled and the fail delay on all the tables is 0 except \mod_forum\task\cron_task which has gone to 61440. I've reset the value at 0 and there are no changes

Server Time: Wed, 14 Feb 2018 09:51:13 +0000


Execute scheduled task: Legacy cron processing for plugins (core\task\legacy_plugin_cron_task)
... started 09:51:13. Current memory use 14.3MB.
Running auth crons if required...
Running cron for auth/mnet...
Running enrol crons if required...
Starting activity modules
Processing module function assign_cron ...
... used 4 dbqueries
... used 0.095200061798096 seconds
done.
I've added to the Tracker you linked

 
Average of ratings: -