Cosas de Administradores

Actualización de Moodle 3.3. a 3.4 y LDAP no funciona

 
Imagen de Noa Noe
Actualización de Moodle 3.3. a 3.4 y LDAP no funciona
 

Holaa!! estoy teniendo un problema luego de actualizar mi versión de Moodle 3.3 a 3.4. Por requisitos previos actualicé también de PHP 5.3 a 7.2.

El problema es que cuando quiero ingresar con un usuario de Active Directory me da un error (que pego a continuación): 



Antes funcionaba sin problemas, puede ser que me esté faltando alguna configuración??

Desde ya muchas gracias! y agradezco cualquier ayuda que me puedan brindar.

 
Promedio de calificaciones: -
Imagen de Noa Noe
Re: Actualización de Moodle 3.3. a 3.4 y LDAP no funciona
 

Revisando el log de Apache (error.log) noto el siguiente error:

ldap_int_sasl_init: SASL library version mismatch: expected 2.1.27, got 2.1.25


Además active el modo debug de moodle y me muestra el siguiente error:

Debug info: 

Error code: auth_ldap_noconnect_all

Stack trace:

line 482 of \lib\setuplib.php: moodle_exception thrown

line 2055 of \auth\ldap\auth.php: call to print_error()

line 195 of \auth\ldap\auth.php: call to auth_plugin_ldap->ldap_connect()

line 4296 of \lib\moodlelib.php: call to auth_plugin_ldap->user_login()

line 140 of \login\index.php: call to authenticate_user_login()


Esto puede estar causando el problema? Puede ser un BUG de la versión 3.4 con LDAP???

gracias!!

 
Promedio de calificaciones: -
Imagen de Noa Noe
Re: Actualización de Moodle 3.3. a 3.4 y LDAP no funciona
 

Buenas tardes. Pude solucionar el error y me gustaría compartirlo con la comunidad, el error es que no coincidía la librería: libsasl de APACHE con la de PHP 7. La solución fue copiar y pegar dicha librería que estaba en PHP a APACHE y listo. Se solucionó el error.

El siguiente link me sirvió como guía.

https://www.linuxquestions.org/questions/linux-newbie-8/sasl-library-version-mismatch-expected-2-1-23-got-2-1-22-a-730191/

muchas gracias!!

 
Promedio de calificaciones:Útil (3)