General developer forum

Syntax error after upgrade to 3.4

 
Picture of Peshali Randika
Syntax error after upgrade to 3.4
 

 I upgrade the moodle 3.3 to 3.4 successfully. After that when I navigate to Home It shows 

 "Syntax error, unrecognized expression: [data-region=`drawer-toggle`] button[data-action=`toggle-drawer`]"

How can I overcome this error? 

Any help ,Thanks in advance

-Peshali

 
Average of ratings: -
Picture of Peshali Randika
Re: Syntax error after upgrade to 3.4
 

After debugging I got this.

If anyone familiar with this.. Please help

sad



 
Average of ratings: -
Picture of Matteo Scaramuccia
Re: Syntax error after upgrade to 3.4
Core developersParticularly helpful MoodlersPlugin developers

Hello,
please uninstall the klass theme: https://moodle.org/plugins/theme_klass tells that it is compatible w/ up to Moodle 3.1 in the Directory tags.

Otherwise, check that all the files of that theme are there.

HTH,
Matteo

 
Average of ratings: -
Picture of Peshali Randika
Re: Syntax error after upgrade to 3.4
 

Thank you very much Matteo.. ! I will check on this. smile

 
Average of ratings: -
Picture of Peshali Randika
Re: Syntax error after upgrade to 3.4
 

Hi Matteo,

I uninstalled KLASS theme. But that error is still the same. 

sad

Is there any other way to solve this ?

-Peshali

 
Average of ratings: -
Picture of Matteo Scaramuccia
Re: Syntax error after upgrade to 3.4
Core developersParticularly helpful MoodlersPlugin developers

Hi Peshali,
if you've changed the theme and removed the klass theme even from the filesystem, the full stack error should look different now. Isn't it?

HTH,
Matteo

 
Average of ratings: -
Picture of Peshali Randika
Re: Syntax error after upgrade to 3.4
 

Hi Matteo,

The error is still same. sad

Thank you for the reply.

-Peshali


 
Average of ratings: -
Picture of Matteo Scaramuccia
Re: Syntax error after upgrade to 3.4
Core developersParticularly helpful MoodlersPlugin developers

Hi Peshali,
I mean: if you enable the Moodle debugging at DEVELOPER level do you still read something like the error reported in https://moodle.org/mod/forum/discuss.php?d=363408#p1465620 ?

TIA,
Matteo

 
Average of ratings: -
Picture of Peshali Randika
Re: Syntax error after upgrade to 3.4
 

Hi Matteo ,

Thanks for the help. Now it looks like this. sad

I couldn't fix that error yet .


 
Average of ratings: -