General help

Increase Variable Limit?

 
Picture of Ken Task
Re: Increase Variable Limit?
Particularly helpful Moodlers

Let's review this thread ...

it begins with

"I could try to increase php_max_input_vars but I've read elsewhere that doing so could included security risks, which I'd like to avoid."

Initial response informed max_input_vars setting was a per directory ... can could be applied via .htaccess in the directory where you want the value to increase or via php.ini in directory where you want that value to increase.

I assumed you were concerned about security risks ... and tried to link to things related to 'security risks' which was a poor attempt to say ... 'everything has an element of risk' on port 80 these days.

But ... moodle security is pretty good ... moodledata should be well protected ... only php scripts from moodle code related to backups/restores would have access (unless you as the administrator of that server have done something to allow.

See:

https://www.cvedetails.com/vulnerability-list/vendor_id-2105/product_id-3590/Moodle-Moodle.html

Look down the list ... note the version of Moodle and see if any involve (specifically) max_input-vars and moodledata or just moodledata

https://www.cvedetails.com/google-search-results.php?q=moodle+moodledata&sa=Search

Please see:

https://docs.moodle.org/33/en/Security_recommendations

note that is for 3.3 ... and from eveything one can read about reasons for security breaches and how to prevent them, think you'll find that the #1 recommendation is to always keep software up to date.

Administration of your server is up to you ...  the method by which you address those security concerns is up to you also ... that's really the bottom line. ;)

'spirit of sharing', Ken

 
Average of ratings: -
Picture of Roman Cylwa
Re: Increase Variable Limit?
 

Hi again,

I will be working on this from a test server and if it's successful and the security risks are viable then we'll apply this same technique to the production server.

I have modified the php.ini file to include [PATH=C:\My_Moodle_Directory] and when I compare the phpinfo values for localhost and for this directory I do see the differences between the local and master values for max_input_vars settings. When I restart the server and launch Moodle I will get an error stating a 'database driver problem detected' and 'Microsoft Drivers for SQL Server for PHP are not installed or not configured properly'. I've checked and the drivers are good on the test server and when I comment the [PATH=] in php.ini and restart this problem is gone.

Any idea why Moodle may be behaving this way or how to proceed for here?

Thanks again.

 
Average of ratings: -