Installing and upgrading help

Trouble in new Moodle Installation (Windows Package)

 
Picture of Irawan Tan
Trouble in new Moodle Installation (Windows Package)
 

Hi all,

I want to test using Moodle, so I download the Complete Windows Package version 3.4 from moodle.org, after I extract the ZIP, I run the "Start Moodle" and what I got is a command prompt like in the attachment then after a while it gone.

My testing laptop is an Intel i3 with 6GB RAM running Windows 10 and I've already read Installation FAQ problem at moodle.org, and I don't have Skype installed. Any hint or help is very appreciated. Thank you


 
Average of ratings: -
Picture of Marcus Green
Re: Trouble in new Moodle Installation (Windows Package)
Core developersParticularly helpful MoodlersPlugin developersTesters

What do you see if you type localhost into the url bar of a browser on your machine?


 
Average of ratings: -
Picture of Irawan Tan
Re: Trouble in new Moodle Installation (Windows Package)
 

I got nothing (no webpage found). When I check in Task Manager, httpd is not running, but mysqld is running. If I try "Stop Moodle", it says "Can't find apache\logs\httpd.pid", hangs for a while, after that "Thanks for using Moodle". And when I check in Task Manager, mysqld is now gone

 
Average of ratings: -
Picture of Usman Asar
Re: Trouble in new Moodle Installation (Windows Package)
Particularly helpful MoodlersPlugin developers

Irawan, do you have a third party firewall installed? if not MySQL already. skype only creates issues with Apache on Port 80, but your issue clearly points towards MySQL.


 
Average of ratings: -
Picture of Irawan Tan
Re: Trouble in new Moodle Installation (Windows Package)
 

Hi Usman, thx for the answer, my firewall is only the basic that comes with Windows. I don't know what my laptop's issues are, but I have tried the manual way. I already got the Apache working now. I use the command prompt httpd -k install -n "Apache2", after that net start Apache2. I open browser, and type localhost, and the start page for Moodle setup showed. Now just trying to figuring out this MariaDB thing

 
Average of ratings: -