General help

A trouble occurs after I upgraded my site from 3.3 to 3.4

 
Picture of Rick Jerz
Re: A trouble occurs after I upgraded my site from 3.3 to 3.4
Particularly helpful Moodlers

A couple things...

1) The best rule is "backup before upgrading." Always.

2) Always read the requirements of moodle before upgrading.

Relative to these two points...

1) When upgrading to 3.4, it might be that it never really happened because your new moodle didn't pass the built in checks.  Did you ever get to the point "Updating the Database" of the new install?  If not, you might be able to reinstall Moodle 3.3 and your database and moodledata might be fine.  Before doing anything, backup both your MySQL database and your moodledata folder.

2) Moodle 3.4 requires php 7.  You might still have php 5.x on your shared hosting plan.  Also, Moodle 3.4 has some database requirements that a Godaddy hosted server typically does not support.  You might need a VPS.

 
Average of ratings: -