General help

A trouble occurs after I upgraded my site from 3.3 to 3.4

 
Picture of Alexander Kuo
A trouble occurs after I upgraded my site from 3.3 to 3.4
 

Hi,

    My site(3.3) worked well and I am happy with its performance. Unfortunately, the trouble came after I upgraded it from v.3.3 to v.3.4 two days ago. Only one account logged into it, but he got an error message "ERR_EMPTY_MESSAGE." Pressing "UNLOAD" button can't solve it. I ever tried to flush DNS. At the beginning, it worked fine, but it failed again after a while. Any suggestion?

Moodle version: 3.4+ 
Host: GoDaddy
PHP Version: 7.1

Alexander, Kuo


 
Average of ratings: -
Picture of Rick Jerz
Re: A trouble occurs after I upgraded my site from 3.3 to 3.4
Particularly helpful Moodlers

I have no clue, but I do wonder how you upgraded?  Do you have a GoDaddy VPS?  Do you use many add-ins?

Consider installing an experimental Moodle from scratch, and see what happens.

 
Average of ratings: -
Picture of Alexander Kuo
Re: A trouble occurs after I upgraded my site from 3.3 to 3.4
 

Thanks for your suggestion.

My Moodle site is based on a shared hosting of GoDaddy, so I can't view the error_log message of Apache.

On a GoDaddy shared host, I have successfully upgraded my Moodle to a newer version many times. Due to these successful experiences, I didn't backup Moodle database this time. And it hurt me!



 
Average of ratings: -
Picture of Rick Jerz
Re: A trouble occurs after I upgraded my site from 3.3 to 3.4
Particularly helpful Moodlers

A couple things...

1) The best rule is "backup before upgrading." Always.

2) Always read the requirements of moodle before upgrading.

Relative to these two points...

1) When upgrading to 3.4, it might be that it never really happened because your new moodle didn't pass the built in checks.  Did you ever get to the point "Updating the Database" of the new install?  If not, you might be able to reinstall Moodle 3.3 and your database and moodledata might be fine.  Before doing anything, backup both your MySQL database and your moodledata folder.

2) Moodle 3.4 requires php 7.  You might still have php 5.x on your shared hosting plan.  Also, Moodle 3.4 has some database requirements that a Godaddy hosted server typically does not support.  You might need a VPS.

 
Average of ratings: -