Installing and upgrading help

Can't get past plugins check

 
Picture of Guido Pinkernell
Can't get past plugins check
 

I have run into this problem when upgrading from 3.2 to 3.3 without being able to have it solved. 

Eventually I restored the mysql moodle database and moodledata from my last running 3.2 installation and started a fresh install with the latest 3.2. Again, there were a few plugins to be upgraded, among these question type plugin "stack". This plugin and all other plugins upgrade fine, but "stack" depends on three further plugins which cause this being stuck on the plugins check page:


The "new version" numbers are in fact the version numbers of the newest plugin versions on the plugin repositories, the "current version" numbers are not available any more. The "required" version numbers seem pretty old to me. I have no idea how to proceed. All three plugins are tagged to be compatible with 2.7 up to 3.3.

Thanks in advance!

 
Average of ratings: -
Picture of Howard Miller
Re: Can't get past plugins check
Core developersDocumentation writersParticularly helpful MoodlersPlugin developers

If you check the github repositories for those plugins, the newest versions are the ones marked as "current version". So you have, somehow, overwritten the code with an older version. Replace with the latest version (from github if you have to) and you should be fine. 

It looks like the Moodle plugins database hasn't been updated to the latest version (for some reason).

 
Average of ratings: -
Picture of Guido Pinkernell
Re: Can't get past plugins check
 

Thanks Howard, problem is (see my more detailed post below) that downloading does provide the latest versions, but after uploading and installing the ZIPs the error screen still appears. 

 
Average of ratings: -
Picture of Howard Miller
Re: Can't get past plugins check
Core developersDocumentation writersParticularly helpful MoodlersPlugin developers

Yeh - you'll need to install the correct plugins 'manually' by downloading them from github (the plugin page for each gives you the link to the source control page). 

You can't get them from the plugins page as that doesn't have the latest version. 

You MUST have got them from Github previously...

 
Average of ratings: -
Picture of Guido Pinkernell
Re: Can't get past plugins check
 

Right, that was it.

This time I avoided "download" from plugin check page and uploading into "place ZIP here", which also was shown on plugin check page, but did the upgrade by command line as described on each plugin info page.

Thanks all for putting me on the right track.

 
Average of ratings: -
Picture of Guido Pinkernell
Re: Can't get past plugins check
 

To complete the picture:

I mentioned this problem in a different thread where I asked for a solution more closely related to the plugins involved. (Remove plugin related tables from the database and start with a fresh install all over.) There, Tim suggested to get the files for the 2016022900 versions of these plugins, which, to me, explains what to make of the screen message.

However: I did install these versions. During the install process, various plugins needed to be upgraded. Some could be upgraded simply by clicking on a button "Upgrade now" (or s.th. like that). Upgrading went fine here, among these plugin STACK, which upgraded to 4.0.1. The three culprits above were tagged for upgrading too. But here, there was no "Upgrade now" button. Instead there was a message like "not on disk" and a download link, which provided files of version 2016022900, or to be more precise: *_moodle33_2016022900.zip. Installing process via "place Zip here" (?) went fine too, but apparently then something got wrong, the next page was the one you see above.

 
Average of ratings: -