Installing and upgrading help

Iconv PHP extension need to be enable

 
Picture of Abu Ali
Iconv PHP extension need to be enable
 

dear Moodle Expert,

I am installing the moodle3.4 version and i am getting the following error.

Moodle requires the iconv PHP extension. Please install or enable the iconv extension.


please help me to find the solution.

thanks

 
Average of ratings: -
Picture of Howard Miller
Re: Iconv PHP extension need to be enable
Core developersDocumentation writersParticularly helpful MoodlersPlugin developers

You need to install the iconv extension...

Helping you depends on what operating system you are running and how PHP was installed?

For example, on Ubuntu/Debian style Linux it would be 

sudo apt install php-iconv

...other configurations will vary

 
Average of ratings: -
Picture of Abu Ali
Re: Iconv PHP extension need to be enable
 


Thanks Howard,

I have purchased dedicated server on blue host and i think they are using linux. What can i do for this? should i talk with the help desk or shoudl do something on control panel,

 
Average of ratings: -
Picture of Howard Miller
Re: Iconv PHP extension need to be enable
Core developersDocumentation writersParticularly helpful MoodlersPlugin developers

I don't know if you can install PHP extensions through the control panel.  It's almost certainly easiest to ask BuleHost's support service. 

 
Average of ratings: -
Picture of Rick Jerz
Re: Iconv PHP extension need to be enable
Particularly helpful Moodlers

Abu, is this the only error that you are getting?  Usually, if intl is missing, other extensions can also be missing.

I am somewhat familiar with cPanel (on my GoDaddy servers.) There is a tool called "EasyApache4" or the older "EasyApache3".  This is the tool that Bluehost might be referring to.  See if you have it.

I must warn you that even though this tool has the word "Easy" in it, it may not be all that "easy" to use.  Its a bit of t tricky utility, both #3 and #4.  But this tool is probably easier to make these changes than using a terminal program (unless you are Howard and know what you are doing. smile )

If you find that intl is installed, you might need to enable it by uncommenting the appropriate line in your php.ini file.

 
Average of ratings: -