Installing and upgrading help

Converting to Barracuda on 1and1: Moodle 3.4

 
Picture of Dave Emsley
Converting to Barracuda on 1and1: Moodle 3.4
Particularly helpful Moodlers

Hi there,

My hosting service is 1and1 and I'm trying to install 3.4 via git.

So the install of Moodle works fine into the right folder but the error about Antelope/Barracuda comes up on install.

According to this page: https://docs.moodle.org/34/en/Administration_via_command_line#Tool_for_converting_tables there are two command line commands to run but when I do I get the error messages:

X-Powered-By: PHP/4.4.9
Content-type: text/html

<br />
<b>Parse error</b>:  syntax error, unexpected T_OBJECT_OPERATOR in <b>/homepages/39/dxxxxxxxxx72/htdocs/xxxxxxxxxxxxx/moodle/admin/cli/mysql_compressed_rows.php</b> on line <b>70</b><br />


Looking at the first line of this it's not trying to run an early version of PHP is it?

Other than that any ideas please?

Cheers

Dave


 
Average of ratings: -
Picture of Dave Emsley
Re: Converting to Barracuda on 1and1: Moodle 3.4
Particularly helpful Moodlers

I rather think that the thread on https://moodle.org/mod/forum/discuss.php?d=350838 has answered this unless someone can shine further light on it?


Cheers

Dave

 
Average of ratings: -
Picture of Ken Task
Re: Converting to Barracuda on 1and1: Moodle 3.4
Particularly helpful Moodlers

The x-powered line shows a very old version of php ... that's why you get the error.

Since you have command line, issue these commands:

which php

should show the path to the cli php ... like /usr/bin/php

Then: /path/to/the/php/you/see/above/php -v

which should show the version.

With Moodle 3.4 one should be running php 7.0.x now.

https://docs.moodle.org/dev/Moodle_3.4_release_notes

You might need to contact 1and1 helpdesk to find out how to use a higher version of php.

According to this:

https://help.1and1.com/hosting-c37630/scripts-and-programming-languages-c85099/php-c37728/determine-what-version-of-php-is-being-used-a704135.html

helpdesk would need to help.

Be careful about taking advice in other postings and attempting to apply them to your instance ... may not be the same operating system (which means commands won't work) ... that's unless the posting did discuss/show 1and1 hosting.

'spirit of sharing', Ken


 
Average of ratings: Useful (1)
Picture of Dave Emsley
Re: Converting to Barracuda on 1and1: Moodle 3.4
Particularly helpful Moodlers

Hi Ken,  Thanks for that; that's what I thought too. 

However the website thinks it is running 7.1.   I've wound back to 3.3.1 to ponder this.


Cheers

Dave


PS "Be careful about taking advice in other postings and attempting to apply them to your instance ... may not be the same operating system (which means commands won't work) ... that's unless the posting did discuss/show 1and1 hosting."   It was on the specific topic of 1and1



 
Average of ratings: -