Installing and upgrading help

Plugins Curren version not shown during installatin

 
Picture of Micho Janssen
Re: Plugins Curren version not shown during installatin
 

Thanks for prompt answer.

Will do, and let you know.

 
Average of ratings: -
Picture of Micho Janssen
Re: Plugins Curren version not shown during installatin
 

Hi,

Long time away.


After some frustrating days with installing IIS, Moodle, PHP, MySQL on Windows Nano Server 2016, I manged to get it to work.
Had to install the system on Windows Server 2016 (GUI) too in order to see some of the error messages, so now I have installed IIS+Moodle+PHP+MySQL on Nano and Standard Windows Server 2016.

The first problem was, as you suggested, script runtime too short. I used 300 on Standard Server and 450 on Nano Server. Will try again with 300 on both. For now, it works.

The resources used were too little. I allocated 16 GB RAM and 4 Processors (2.6 GHz) to the servers, and that did the trick. I have not tried with less, the install failed using 3 GB RAM and 1 vCPU (2.6 GHz).

Another problem on Nano was the IIS config file (ApplicationHost.config) did not update the default document properly to index.php, some tag and spelling issues. On Standard Server I did not have index.php in list of default documents and the install halted (failed), once the list of default douments were updated, the install continued successfully.

Thanks for the assitance.

If you want me to publish the install process (Windows Server 2016 Standard/Nano + IIS 10 + Moodle 3.4 + PHP 7.0.25 + MySQL 5.7.20, and using Powershell), will gladly do, merely point me to correct documentation format and place to publish.

 
Average of ratings: -