Installing and upgrading help

Plugins Curren version not shown during installatin

Picture of Micho Janssen
Plugins Curren version not shown during installatin

I have attempted several times to install Moodle on Windows 2016 nano server.
PHP 7.11 - works, php_intl.dll problems solved (missing api-ms-win-crt-*.dll installed), opcache problem solved (had to reference zend_extension=php_opcache.dll)

MySQL 5.7.15 installed and can manage it with MySQL Workbench.
Created moodle user, created blank moodle database.
Allowed port 3306 through server firewall.

Installed IIS, configured Moodle site. Configured CGI.
Connecting to default IIS site works.
Connecting with browser and requesting PHP info works.

Copied Moodle 3.2.5 started moodle install. Also tried 3.2.5+, 3.3.2, with same results.
All versoins tried creates MySQL database (user, password, database, and port specified), and all the checks pass, 'Your server environment meets all minumum requirements' (complains a little about https not enabled), as per picture attached.

Initial Checks OK

Press 'Continue' button and the next couple of screens differ at times.
Sometimes the word 'Installation' appears, sometimes a message '500 - Internal server error.', sometimes nothing.

After a long wait the following screen showing the Plugins versions appears, the column under 'Current version' is blank, and the installation halts. What to do next to pass this point?

Plugins Current Version not shown

Average of ratings: -
Picture of Emma Richardson
Re: Plugins Curren version not shown during installatin
Documentation writersParticularly helpful MoodlersPlugin developers

It is a new install so there is no current version.

As for the install stalling out, I wonder if you are hitting a timeout somewhere - you might check your php.ini and up your timeout settings and see if that helps.  

Average of ratings: -
Picture of Micho Janssen
Re: Plugins Curren version not shown during installatin

Thanks for prompt answer.

Will do, and let you know.

Average of ratings: -
Picture of Micho Janssen
Re: Plugins Curren version not shown during installatin


Long time away.

After some frustrating days with installing IIS, Moodle, PHP, MySQL on Windows Nano Server 2016, I manged to get it to work.
Had to install the system on Windows Server 2016 (GUI) too in order to see some of the error messages, so now I have installed IIS+Moodle+PHP+MySQL on Nano and Standard Windows Server 2016.

The first problem was, as you suggested, script runtime too short. I used 300 on Standard Server and 450 on Nano Server. Will try again with 300 on both. For now, it works.

The resources used were too little. I allocated 16 GB RAM and 4 Processors (2.6 GHz) to the servers, and that did the trick. I have not tried with less, the install failed using 3 GB RAM and 1 vCPU (2.6 GHz).

Another problem on Nano was the IIS config file (ApplicationHost.config) did not update the default document properly to index.php, some tag and spelling issues. On Standard Server I did not have index.php in list of default documents and the install halted (failed), once the list of default douments were updated, the install continued successfully.

Thanks for the assitance.

If you want me to publish the install process (Windows Server 2016 Standard/Nano + IIS 10 + Moodle 3.4 + PHP 7.0.25 + MySQL 5.7.20, and using Powershell), will gladly do, merely point me to correct documentation format and place to publish.

Average of ratings: -