Dataform (plugin)

PSA: Do NOT upgrade to PHP 7! Stay on 5.6 to keep using this plugin.

 
My profile picture
PSA: Do NOT upgrade to PHP 7! Stay on 5.6 to keep using this plugin.
 

Was pulling my hair out for hours trying to figure out why none of the fields on my activity could be edited.

Turns out that there is an open bug with PHP7 that the Dataform plugin just doesn't play nicely with. I resolved my issue by rolling back to PHP 5.6.

 
Average of ratings: Useful (2)
Picture of Hartmut Scherer
Re: PSA: Do NOT upgrade to PHP 7! Stay on 5.6 to keep using this plugin.
Particularly helpful Moodlers

Thanks for the warning. Today I saw that Moodle 3.4 requires at least PHP 7.0. I like to use the Dataform module. Since I don't know when the updated version of Dataform will be released, I won't migrate to Moodle 3.4. We are now on Moodle 3.3 and hope that the Dataform module will be updated with Moodle 3.5.

 
Average of ratings: -
Picture of Andrew Earley
Re: PSA: Do NOT upgrade to PHP 7! Stay on 5.6 to keep using this plugin.
 

Dear TJ 

Do you have a link to this tracker? I am struggling to find it.

 
Average of ratings: -