General developer forum

Custom theme displaying language identifiers instead of the values

 
Picture of Nathan Hunt
Custom theme displaying language identifiers instead of the values
 

I've been following the https://docs.moodle.org/dev/Creating_a_theme_based_on_boost tutorial and have got it all working, even uploading an image and having it appear on the background of the login page.

My issue is when I go to my themes settings page, it is just displaying the language identifiers inside double square brackets like configtitle

See snippet below:



Does anyone have any ideas on why it does this, I've tried searching but haven't got anywhere with finding anything remotely close to this.

In the root of my theme, I have lang/en/theme_photo.php

Any help would be much appreciated.

 
Average of ratings: -
Picture of AL Rachels
Re: Custom theme displaying language identifiers instead of the values
Core developersParticularly helpful MoodlersPlugin developersTesters

Do you have an entry in your language file for those "settings"? generalsettings, advancedsettings, and preset?

 
Average of ratings: -
Picture of Richard Oelmann
Re: Custom theme displaying language identifiers instead of the values
Core developersParticularly helpful MoodlersPlugin developersTesters

If you do have the correct language strings, then try Purging All Caches - that should refresh the language strings (if they are there) as well as any theme settings.

The other option (although shouldn't be necessary if you purge caches, would be to increment your version in your theme config.php and go back to the notification page - that will force an update, including language strings.

 
Average of ratings: Useful (2)
Picture of Nathan Hunt
Re: Custom theme displaying language identifiers instead of the values
 

Thank you so much, it seems I had to change the version number and go back to the notifications page! Would have never figured that out haha.

I did try clearing the cache before and all the strings existed so that was the solution for me, thanks again.

 
Average of ratings: -