Installing and upgrading help

Moodle web site appears as textual only

 
Picture of Jukka Kylliäinen
Moodle web site appears as textual only
 

Hi,

We have Moodle version 3.3 + (Build:20170608) installed in Windows server 2016 with Apache and mysql.

Moodle server is in DMZ area and it's published with load balancer.

We can open moodle web site in server itself, but when trying to connect with browser from internet, the web site opens as in textual layout.


 
Average of ratings: -
Picture of Jorge Dávila López
Re: Moodle web site appears as textual only
 

Hi Jukka,

You should verify the config.php file and check if the URL setting is ok for your Moodle installation.

If you changed the theme recently verify too the theme version is according to your installation.

Hope this helps,

Jorge Dávila.

 
Average of ratings: -
Sketch...
Re: Moodle web site appears as textual only
Particularly helpful Moodlers

And check the Moodledata folder permissions. Apache must have read/write/update/delete permissions to all the files and folders in Moodledata.

If that doesn't help try adding this to your Moodle config.php file:

$CFG->directorypermissions = 0777;


 
Average of ratings: -
Sketch...
Re: Moodle web site appears as textual only
Particularly helpful Moodlers
Moodle server is in DMZ area and it's published with load balancer.

Do you have a multi-node server setup? If so, how many nodes? And where do you store your Moodledata folder?

 
Average of ratings: -
Sketch...
Re: Moodle web site appears as textual only
Particularly helpful Moodlers

Lastly, try disabling the Use slash arguments option under Site Administration > Server > HTTP.

 
Average of ratings: -
Picture of Jukka Kylliäinen
Re: Moodle web site appears as textual only
 

Hi,

I almost sure, that I found the reason to as textual only.

As I said the site is published with load balancer, so from internet  to the load balancer the trafiic is SSL and from load balancer to the moodle server traffic is without SLL.

When opening the from server using HTPPS, the site open as textual.

Is there any resolution for that or should I install certificate for apache and publish Moodle without load balancer (with proxy)??



 
Average of ratings: -
Picture of Jukka Kylliäinen
Re: Moodle web site appears as textual only
 

Hi,

Just to make sure, that I can install (step by step) certificate to the apache in windows Server.

I have tree files .crt, .key and .crt. I copied files to the server. There are two config files httpd.conf and httpd-ssl.conf. Should I edit the httpd-ssl.conf file or ???


 
Average of ratings: -
Sketch...
Re: Moodle web site appears as textual only
Particularly helpful Moodlers

What are you using in your $CFG->wwwroot? HTTPS or HTTP?

 
Average of ratings: -
Picture of Emma Richardson
Re: Moodle web site appears as textual only
Documentation writersParticularly helpful Moodlers

Have you checked your fire wall?  Installing the cert on moodle shouldn't make any difference - did you add the proxy line to the config file?  

 
Average of ratings: -
Sketch...
Re: Moodle web site appears as textual only
Particularly helpful Moodlers

IIS is built into Windows Server so it doesn't really make sense to use Apache on Windows Server. You just create more setup and maintenance work for yourself...

 
Average of ratings: -