Piazzale Italia

moodle .2.2.7 o successive

 
Immagine Riccardo Frattini
moodle .2.2.7 o successive
 

buongiorno sapete dove è possibile scaricare la versione 2.2.7 ?

grazie

 
Media dei voti:  -
Immagine Matteo Scaramuccia
Re: moodle .2.2.7 o successive
Core developersParticularly helpful MoodlersPlugin developers

Ciao Riccardo,
l'ultima 2.2.x, la 2.2.11 è disponibile scrollando nella pagina https://download.moodle.org/releases/legacy/.

Per la 2.2.7 invece, https://github.com/moodle/moodle/releases/tag/v2.2.7.

Sei certo che non sia una weekly cioè una 2.2.7+ quindi una versione intermedia tra la 2.2.7 e la 2.2.8?
Nel qual caso è necessario sapere anche il numero che trovi nella parentesi dopo la versione: ad esempio la 2.2.7 è in realtà indicata come 2.2.7 (Build: 20130114).

Ovviamente devo ricordarti di verificare tutte le tue buone ragioni per usare una versione così vecchia e non più supportata ammiccante.

HTH,
Matteo

Immagine Riccardo Frattini
Re: moodle .2.2.7 o successive
 

la versione che ho ora è questa 

Moodle 2.2.6+ (Build: 20121130)

un virus mi ha danneggiato la piattaforma ed ora non mi consente piu di creare corsi, esportare e importare,  aggiungere utenti ne di modificare le cose che ci sono ora, ora che ho risolto con il virus ho pensato che aggiornandola alla versione successiva mi possa far risolvere in parte

cosa mi consigli?


Immagine Matteo Scaramuccia
Re: moodle .2.2.7 o successive
Core developersParticularly helpful MoodlersPlugin developers

Ciao Riccardo,
dovresti valutare l'entità del danno per capire se il tuo sia il percorso giusto: https://docs.moodle.org/22/en/Hacked_site_recovery.

Se avessi un backup aggiornato dei corsi sarebbe meglio installare:

  • lo stesso codice
  • importare i backup
  • veriicare che tutto funzioni
  • aggiornare alla ultima 2.2.x
  • fare tutti i passaggi richiesti per portarla almeno alla (ultima) 2.7, sempre che le eventuali componenti terze parti (temi, plug-in) siano disponibili anche per la 2.7

Se ti mancano i backup, bisognerebbe capire prima che cosa "il virus" abbia rotto in Moodle - direi anche capire come sia stato possibile: buco di sicurezza in Moodle, che aggiornamenti successivi hanno eliminato, o problema nel server quindi  che prescinde da Moodle e che allora potrebbe ricapitare? - per capire se l'aggiornamento all'ultima 2.2.x possa sbloccare l'attuale empasse.

HTH,
Matteo

Immagine Riccardo Frattini
Re: moodle .2.2.7 o successive
 

infatti non ho il backup e aggiornando o rimettendo la stessa versione credevo di risolvere o almeno avrei fatto un tentativo

sai in in caso dove la posso scaricare la versione che ho ora?

Immagine Matteo Scaramuccia
Re: moodle .2.2.7 o successive
Immagine Riccardo Frattini
Re: moodle .2.2.7 o successive
 
grazie Matteo gentilissimo