Security announcements

MSA-17-0020: Admins may not know that exposing vendor directory is a security risk

 
Picture of Marina Glancy
MSA-17-0020: Admins may not know that exposing vendor directory is a security risk
 

Directories vendor/ and node_modules/ that are created by composer and used during Moodle development may expose dangerous scripts to the web and should never be present on production sites. This issue adds a respective security check.

Manual action may be required from the site admin to remove composer-generated directories or prevent access to them from the web.

Severity/Risk: Serious
Versions affected: 3.3 to 3.3.1, 3.2 to 3.2.4, 3.1 to 3.1.7 and earlier unsupported versions
Versions fixed: 3.3.2, 3.2.5 and 3.1.8
Reported by: David Mudrák
CVE identifier: CVE-2017-9841 reported against PHPUnit project, it is relevant to the version used in Moodle development
Changes (master): http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-59969
Tracker issue: MDL-59969 Admins may not know that exposing vendor directory is a security risk