Assistance technique

Moodle 3.3.2 - Section 0 masquée, impossible à afficher

 
Avatar Nicolas Martignoni
Re: Moodle 3.3.2 - Section 0 masquée, impossible à afficher
DéveloppeursDéveloppeurs de pluginsDocumentation writersMoodleurs particulièrement utilesTesteursTraducteurs

C'est assez étrange, je n'arrive pas à reproduire ceci sur une plateforme fraîchement installée (3.3.2, en Clean). Le menu en face de la section 0 comporte tous les éléments.

 
Moyenne des évaluations  -
Avatar Bruno Malaval
Re: Moodle 3.3.2 - Section 0 masquée, impossible à afficher
Moodleurs particulièrement utiles

En 3.3.2 également, j'ai le même comportement (menu de la section 0 ne comporte que modifier la section)

Et ce pour les thèmes clean / boost / more , même après avoir vider le cache

La remarque "fraîchement installée" est peut-être la bonne piste.

Une information non mise à jour ou mal mise à jour lors de l'upgrade ?

 
Moyenne des évaluations  -
Avatar Patrick Lemaire
Re: Moodle 3.3.2 - Section 0 masquée, impossible à afficher
Moodleurs particulièrement utiles

Bonjour Nicolas,

Tu écris : « Le menu en face de la section 0 comporte tous les éléments » Est-ce que ça veut dire que tu as une possibilité de masquer la section zéro ? surprise

A bientôt,
Patrick

 
Moyenne des évaluations  -
Avatar Nicolas Martignoni
Re: Moodle 3.3.2 - Section 0 masquée, impossible à afficher
DéveloppeursDéveloppeurs de pluginsDocumentation writersMoodleurs particulièrement utilesTesteursTraducteurs

Salut Patrick,

Non, désolé, je me suis mal exprimé. Le seul élément du menu de la section 0 est « Modifier la section » (je viens de re-vérifier).

Pardon pour la mauvaise formulation.

N.

 
Moyenne des évaluations  -
Avatar Philippe Gillet
Re: Moodle 3.3.2 - Section 0 masquée, impossible à afficher
 

Bonjour,

Je teste la migration de la version 2.8.5+ vers la version 3.3.2 et j'ai notamment un problème d'affichage

En routine (2.8.5+), aucun problème d'affichage

En validation (3.3.2), partie "cachée pour les étudiants" et pages "disponibles mais pas affichées sur la page de cours:

Aucun paramètre ne me semble permettre de modifier l'affichage.

Merci pour toute solution qui me permettra de corriger cet affichage. Sur 20 cours, c'est le seul cours qui me pose des problèmes d'affichage et je souhaite vraiment passer à une version 3.3

Belle journée

Philippe

 
Moyenne des évaluations  -
Daniel
Re: Moodle 3.3.2 - Section 0 masquée, impossible à afficher
Moodleurs particulièrement utiles

Bonjour,

Si j'ai compris... pas certain...

Les paramètres d'affichage devraient se trouver en liste déroulante dans le menu modifier/paramètres/réglages courants.

Vous devriez voir plusieurs choix dont celui de l'activité furtive qui semble être le cas du forum.

menus

La section est cachée également, semble-t-il ?

Pour cela passez dans un thème graphique standard et le menu va peut-être changer?

Par exemple certains thèmes graphiques n'intègrent pas encore ce menu "activités furtives".

Il faut d'ailleurs que je signale cela aussi pour le thème Essential...

Votre thème graphique est-il adapté et validé à 100% pour 3.3 ?

Daniel

PS: Il faut penser à activer les activités furtives dans votre administration Moodle: Fonctions avancées.

 

 
Moyenne des évaluations Utile (1)
Avatar Philippe Gillet
Re: Moodle 3.3.2 - Section 0 masquée, impossible à afficher
 

Bonjour,

Merci pour toutes vos suggestions. Malheureusement, seule l'option "Cacher pour les étudiants" est disponible, les autres options n'apparaissent (elles apparaissent toutes dans les autres cours).

Dans l'administration du site, la case relative aux activités furtives est cochée (mais elle avait sa valeur par défaut "non" au moment de la migration des données).

La section en elle-même n'est pas cachée, je suis juste surpris par l'affichage des messages en bleu. Si je me connecte en tant qu'étudiant ce qui est "caché" n'est pas visible et ce qui est "disponible mais pas affiché sur la page de cours" est affiché et disponible, avec le même message qui apparaît "disponible mais pas affiché sur la page de cours".

En fait, je teste la possibilité de migrer (enfin) le site vers une version 3.3 et c'est le seul problème que j'ai identifié actuellement, et encore rien que pour un cours.

Le thème graphique est le thème "BOOST"

Peut-être tester une nouvelle migration des données en ayant au préalable coché la case d'activation des activités "furtives"? Personnellement, je ne vois pas d'autre solution à tester.

Merci pour vos suggestions.

Philippe

 
Moyenne des évaluations  -
Avatar Luiggi Sansonetti
Re: Moodle 3.3.2 - Section 0 masquée, impossible à afficher
Développeurs de pluginsMoodleurs particulièrement utilesTesteursTitulaires du Moodle Course Creator CertificateTraducteurs

Bonjour

D'après le visuel du cas 3.2.2, la section "bienvenue" est bien marquée "cachée pour les étudiants"

L'étiquette avec l'ardoise n'a pas de message donc est bine visible

Le forum est marqué "disponible mais pas affiché", donc accessible via un lien pointant vers lui mais pas directement accessible.

Curieux.

Dans le menu "modifier" de la section "bienvenue", il n'y a pas d'autres choix ?

 
Moyenne des évaluations  -
Avatar Philippe Gillet
Re: Moodle 3.3.2 - Section 0 masquée, impossible à afficher
 

Bonjour,

Merci pour votre intérêt envers ce petit souci.

La section "bienvenue" est de fait cachée pour les étudiants et je n'ai pas d'option pour l'afficher (seule option "cacher pour les étudiants").

Idem pour le forum, je n'ai pas d'option pour modifier le statut. Mais connecté en tant qu'étudiant j'y ai accès.

Détail peut-être utile, la version 3.3.2 est une version en environnement de validation avec des données migrées il y a quelques semaines. Il est donc possible que certaines sections étaient masquées au moment de la migration des données, ce qui expliquerait peut-être partiellement le problème. Je compte refaire un test de migration la semaine prochaine (je n'ai pas accès au serveur de mon domicile et la version 3.3.2 n'est pas disponible par "l'extérieur").

A suivre après une nouvelle migration des données?

Encore merci pour votre réactivité

Philippe

 
Moyenne des évaluations  -
Daniel
Re: Moodle 3.3.2 - Section 0 masquée, impossible à afficher
Moodleurs particulièrement utiles

Bonjour,

Le thème graphique Boost est peut-être celui choisi pour Moodle mais peut-être pas celui de CE cours lui-même?

Car j'ai eu le cas de l'option "rendre invisible mais disponible sur la page de cours" qui n'apparaissait pas avec d'autres thèmes graphiques.

Bien entendu une solution serait de nous fournir (cloud?) la sauvegarde de ce cours afin qu'on teste chez nous ?

 
Moyenne des évaluations  -
Avatar Philippe Gillet
Re: Moodle 3.3.2 - Section 0 masquée, impossible à afficher
 

Le thème graphique du cours est identique. Le problème a été résolu par la solution de Christian ( rendre la section visible dans mdl_course_sections via Adminer)

Merci pourt tous vos conseils.

Philippe

 
Moyenne des évaluations  -
Daniel
Re: Moodle 3.3.2 - Section 0 masquée, impossible à afficher [Résolu]
Moodleurs particulièrement utiles

Bonjour Philippe,

Toucher à la base de données n'est pas du ressort du premier utilisateur venu, même administrateur de son Moodle.pensif

Heureusement qu'il y a des spécialistes dans la communauté. Ce qui n'est pas mon cas.

Pour info, si ton problème est résolu, tu le signales comme je l'ai fait dans le titre du fil.

 

 
Moyenne des évaluations  -
Avatar Christian Bocquet
Re: Moodle 3.3.2 - Section 0 masquée, impossible à afficher
Moodleurs particulièrement utiles

Bonjour,

Avez-vous essayé de passer par la base de données mdl_course_sections comme indiqué dans les messages de Séverin, Eric et moi-même dans les messages précédents de ce fil de discussion ?

Quand je fais le chemin inverse pour la section 0 d'un cours, en passant la valeur du champ "visible" de 1 (visible) à 0, et en vidant les caches ( Administration du site  ► Développement  ► Vider tous les caches ) , j'obtiens le même phénomène que sur votre copie d'écran :




Christian

 
Moyenne des évaluations Utile (1)
Avatar Philippe Gillet
Re: Moodle 3.3.2 - Section 0 masquée, impossible à afficher
 

Bonjour,

Merci pour votre démonstration. Je ne suis qu'administrateur de Moodle sans accès direct au serveur en dehors de Moodle. Je suppose que dans ce cas, je ne saurai pas résoudre moi-même le problème et que je devrai demander la semaine prochaine à un collègue du service informatique? Si la solution est accessible par Moodle puis Administration du site, je suis curieux de savoir comment.

J'espère tester votre solution la semaine prochaine, n'ayant pas accès à la version test de mon PC domicile via une connexion VPN (affichage très bizarre).

Encore merci

Philippe

 
Moyenne des évaluations  -
Avatar Christian Bocquet
Re: Moodle 3.3.2 - Section 0 masquée, impossible à afficher
Moodleurs particulièrement utiles

Le plugin Moodle Adminer permet d'accéder à la base de données. Vous pouvez télécharger le fichier zip ici pour la version 3.3 et l'installer en suivant le chemin : Administration du site ► Plugins ► Installer des plugins.

Ensuite pour accéder à la base de données, vous suivez le chemin : Administration du site ► Serveur ► Moodle Adminer

Chercher et sélectionner mdl_course_sections, cliquer sur "Afficher les données", chercher la section 0 (colonne section) de votre cours (colonne course - penser à récupérer son identifiant avant) et cliquer sur l'icône d'édition. Remplacer la valeur du champ "visible" par 1 (si, comme je le pense, vous trouvez la valeur 0), puis cliquer sur le bouton "Enregistrer".

Enfin vider les caches et vérifier si le problème est résolu.

Christian

 
Moyenne des évaluations Utile (1)
Avatar Philippe Gillet
Re: Moodle 3.3.2 - Section 0 masquée, impossible à afficher
 

Merci, je ne pourrai malheureusement tester que la semaine prochaine avec mon PC professionnel vu qu'il s'agit d'une version test installée sur un serveur local à laquelle l'accès via VPN n'est pas au top.

 
Moyenne des évaluations  -
Avatar Philippe Gillet
Re: Moodle 3.3.2 - Section 0 masquée, impossible à afficher
 

Bonjour et merci à tous,

Avec un peu de persévérance, j'ai pu accéder à la version test installée par le service informatique.

J'ai appliqué étape par étape la procédure très claire de Christian et le problème est résolu.

C'est super; déjà fan de Moodle, je suis encore plus enthousiaste.

Le problème est donc résolu et je vous remercie tous pour votre implication constructive.

Bonne année 2018

Philippe

 
Moyenne des évaluations  -