MoodleCloud

'Invalid user' error

 
Holmeschool eLearning
'Invalid user' error
 

I have juts started getting an 'Invalid user' error (see picture below) every time I try to login to my moodle.school site using my admin credentials. This has just started happening about half an hour ago and I need  access to the site for a class I am teaching tonight! Can anyone help - Please!!


 
Average of ratings: -
Picture of Vernon Spain
Re: 'Invalid user' error
Plugin developers

Are you using OAUTH2 ? Is it the dashboard page?

I'm getting the same, just with the main admin account.

If it's OAUTH2 I suspect it may be something to do with issues that Google is having today?


Does anyone else have any suggestions?


For now, you can bypass the Dashboard and access things by going around the dashboard page by going to https:/www.yoursite.com/course/index.php 


Then turn off the dashboard temporarily.

This worked for me.


 
Average of ratings: -
Holmeschool eLearning
Re: 'Invalid user' error
 

Thanks for the reply.

No I wasn't getting the OAuth2 issue.

I tried clicking the link you posted but it brings up a malware spoof Microsoft alert with a number telling me to call them to fix my computer and warning me not to close the message before calling otherwise my computer will be locked. You might want to check the link as other people may use it and call the number which, apparently, if you do, the scammers will demand lots of money and put your computer into lock down!

Microsoft are aware of this scam and there are lots of posts on their help pages about it. I followed the advice to shut down and restart my computer.


The Moodle HQ support team are dealing with the issue on my Moodle.school site now.


 
Average of ratings: -
Picture of Vernon Spain
Re: 'Invalid user' error
Plugin developers

Hi Sarah,

www.yoursite.com is just a way of demonstrating an address.

So https://www.yousite.com/course/index.php would be my way of telling you to go to

Englishlgcse.moodle.school/course/index.php as a way of bypassing the dashboard (and learning plan block).

This would have allowed you access to the admin menus to fix (turn off) the leaning plan block and recover the dashboard.

It was helpful to know about the learning plan block issue.

Thanks for posting.

Regards,

Vernon


 
Average of ratings: -
Picture of Jordan Tomkinson
Re: 'Invalid user' error
 

Hi Sarah,


We are investigating this issue and have put the site into maintenance mode.


I will get back to you shortly.

 
Average of ratings: Useful (2)
Picture of Jordan Tomkinson
Re: 'Invalid user' error
 

Hi Sarah,


Your site was affected by this bug in Moodle: https://tracker.moodle.org/browse/MDL-59994

To temporarily fix your site I removed the 'lp' block.

As soon as the Moodle core team have fixed this issue in Moodle itself, we will deploy this to MoodleCloud.

In the meantime, please do not delete a user that is waiting for competency review by manager/administrator (as per the tracker issue)

 
Average of ratings: Useful (2)
Holmeschool eLearning
Re: 'Invalid user' error
 

Thanks for your reply. My Site came back on line and I was able to log in and access the course but when I tried adding the learning plan block again I have been locked out and now see the 'invalid user' message again. Is this a permanent bug which means I should not even attempt to add the LP block to courses?

I've messaged support so I suspect they will have to put the site in maintenance again.

 
Average of ratings: -