Moodle-Technikforum

Serverkonfiguration - site not https

 
Nutzerbild Georg Wiesinger
Serverkonfiguration - site not https
 
Guten Morgen,

seit dem Update von Moodle 3.2 auf Moodle 3.3 ist mir aufgefallen, dass in der Serverkonfiguration plötzlich folgende Meldung erscheint, obwohl bislang sämtliche Stati immer auf grün/Ok waren:

site-not-https

Das SSL-Zertifikat ist gültig, aktiv und ordentlich eingerichtet, es wurde nichts daran geändert. Login über https ist aktiviert und funktioniert auch entsprechend!

Aktuell läuft die neueste Version: 3.3.2

Ist das möglicherweise ein Bug oder müsste ich irgendetwas am Zertifikat/Server ändern?

Vielen Dank im Voraus für jeglichen Rat!

Beste Grüße
Georg

 
Mittelwert:  -
Nutzerbild Andreas Grabs
Re: Serverkonfiguration - site not https
Besonders aktive MoodlerEntwickler

Hallo Georg,

gemeint ist, dass die Seite selbst nicht unter https läuft, also nach dem Login.

Wenn Login über https bereits gut funktioniert, kannst du relativ leicht die Seite komplett umstellen.

  • in der config.php den Wert bei "$CFG->wwwroot" ändern von "http://" in "https://"
  • Als Admin anmelden und aufrufen "<deine-seite>/admin/tool/replace"
    • Im ersten Textfeld gibst du deinen alten wwwroot an. Also "http://<deine-seite>"
    • Im zweiten Textfeld gibst du den neuen wwwroot an. Also "https://<deine-seite>"
    • alle Häkchen setzen und bestätigen

Danach ist deine Seite grundsätzlich über https aufrufbar. Es kann aber sein, dass externe Ressourcen z.B. Bilder von einer externen Quelle nicht mehr angezeigt werden, wenn diese nicht auch über https eingebunden sind.

In jedem Fall lohnt es sich, im Vorfeld ein Backup anzufertigen ;).

Viele Grüße
Andreas

 
Mittelwert: Nützlich (2)
Nutzerbild Georg Wiesinger
Re: Serverkonfiguration - site not https
 

Hallo Andreas,

vielen Dank für die ausführliche Anleitung! Ich dachte, dass man Moodle nicht vollständig unter https zwecks Performance laufen lassen soll, da habe ich offensichtlich einige Wissenslücken! Werde sogleich zur Tat schreiten, natürlich mit Backup! lächelnd

Beste Grüße
Georg

 
Nutzerbild Visvanath Ratnaweera
Re: Serverkonfiguration - site not https
Besonders aktive Moodler
Hallo Georg

Heute ist Performance kein Thema mehr, eher https://www.eff.org/https-everywhere.
zwinkernd
 
Mittelwert: Nützlich (1)
Nutzerbild Georg Wiesinger
Re: Serverkonfiguration - site not https
 

Guten Morgen,

nach gründlichen Recherchen und Lesen von Beiträgen in Moodle Docs (HTTP securityTransitioning to HTTPS), die vollends an mir vorüber gegangen sind, bin ich nun im Bilde! lächelnd

Am Testsystem hat die Umstellung bereits einwandfrei funktioniert, einfach spitze!

Vielen Dank für sämtliche Hilfestellungen!

Beste Grüße
Georg