Mathematics tools

Problems with answer tests and "correct responses" after update to Stack 4.0.1

 
Picture of Ute Nachbauer
Problems with answer tests and "correct responses" after update to Stack 4.0.1
 

Hi,

After updating from STACK 3 to STACK 4 I used the script for converting my questions to the new syntax. When testing my questions the following problems occured:

The answer test did not work if I set "Check the type of the response" to "No", but it did work correctly if I changed "Check the type of the response" to "Yes".

If I click on the button "Fill in correct responses" nothing happens and if I click on the button "Check" the answer test is ok but the syntax hint ("can by typed in as follows …") is missing.

Question - "Check the type of the response" set to "No":

Check the type of the response No

Question - "Check the type of the response" set to "Yes":

Check the type of the response Yes

Click on button "Fill in correct responses" => nothing happens

Syntax hint missing

Click on button "Check" => answer test ok., syntax hint ("can by typed in as follows …") is missing

Thanks for your help,

Ute

 
Average of ratings: -
Picture of Christopher Sangwin
Re: Problems with answer tests and "correct responses" after update to Stack 4.0.1
Particularly helpful MoodlersPlugin developers

Did you update your maxima image after the upgrade?  (I think not......!)

Chris


 
Average of ratings: Useful (1)
Picture of Ute Nachbauer
Re: Problems with answer tests and "correct responses" after update to Stack 4.0.1
 

Thanks for your answer. I don't do the installation myself and the person who did it was ill last week. Now he told me there shouldn’t be anything wrong with our maxima. The start of our next semester is very soon, so I decided to stay with STACK 3 for the moment, which is working very well (thanks a lot for this great plugin!). We will try to upgrade again at the end of next semester.

Ute


 
Average of ratings: -
Picture of Christopher Sangwin
Re: Problems with answer tests and "correct responses" after update to Stack 4.0.1
Particularly helpful MoodlersPlugin developers

There almost certainly isn't anything "wrong" with your Maxima, but I expect you have an image saved which need to be upgraded now you have the new STACK code.  This is a 30 second post-install job!

Chris


 
Average of ratings: -
Picture of Ute Nachbauer
Re: Problems with answer tests and "correct responses" after update to Stack 4.0.1
 

I transmitted your answer to the person doing the updates and now the problem is solved.

Thank you very much!

Ute

 
Average of ratings: -