Instalación y Actualización

Instalar moodle 3.2.2 y php 5.6.31

 
Imagen de jaime muñoz
Instalar moodle 3.2.2 y php 5.6.31
 

Estimados


Estoy intentando instalar Moodle 3.2.4+, segun los requerimientos debe tener instalado la version de  PHP 5.6.5,, 

pero solo he podido instalar la version php 5.6.31, he visto en gogole sitios de moodle que usan la version de php 5.6.31


consulta


¿la version moodle 3.2.2 corre bien usando php 5.6.31 o tendrem problemas?

saludos



 
Promedio de calificaciones: -
Randy Thornton
Re: Instalar moodle 3.2.2 y php 5.6.31
Documentadores

Hola Jaime,

Si, Moodle 3.2 funciona bien usando php 5.6.31.

PHP 5.6.5 es solo la versión minima, y 5.6.31 es más nueva (porque 31 > 5). Se recomienda mantener todo su software actualizado y 5.6.31 es la versión novísima. Muchos sitios míos corren usando php 5.6.29, 5.6.30 o 5.6.31 sin problemas.

Saludos,
Randy
 
Promedio de calificaciones:Útil (1)
Imagen de jaime muñoz
Re: Instalar moodle 3.2.2 y php 5.6.31
 

Muchas gracias por la respuesta

 
Promedio de calificaciones: -
GenXConectados
Re: Instalar moodle 3.2.2 y php 5.6.31
 

Podrían dar el link para descargar la version de moodle 3.2.2 para php 5.6.31

 
Promedio de calificaciones: -
Imagen de Jose Luis Martin Jimenez
Re: Instalar moodle 3.2.2 y php 5.6.31
Moodlers de gran ayuda

En la parte de arriba de la página verás un enlace a "DOWNLOADS" que te permite descargar la última versión disponible, pero también verás que en la parte derecha te ofrece enlaces para descargar versiones anteriores:


No está la versión 3.2.2 porque ya está obsoleta, pero sí tienes acceso a la más reciente de esa rama, la 3.2.9 (https://download.moodle.org/releases/legacy/)

No obstante, si el motivo de no usar versiones más recientes es porque tu PHP es versión 5.6.31, te comento que la versión de Moodle 3.3.6 (https://download.moodle.org/releases/security/) también es compatible con esa versión de PHP.

Tú ya eliges ...
Un saludo.


 
Promedio de calificaciones:Útil (1)
GenXConectados
Re: Instalar moodle 3.2.2 y php 5.6.31
 

Subí al host moodle 3.5 y arrojó error por versión php anterior


Subí la versión 2.2.11 y equivoqué añadir la línea de directorio...

dice: Fatal error: $CFG->dataroot is not configured properly, directory does not exist or is not accessible! Exiting.


Probaré luego con la versión: 3.3.6 y seguimos en contacto. 


Gracias!!!


 
Promedio de calificaciones: -
GenXConectados
Re: Instalar moodle 3.2.2 y php 5.6.31
 

Ok

instalé versión: 3.3.6


y arrojó:

Warning: require(/home/genxconectados/public_html/moodle/version.php): failed to open stream: No such file or directory in /home/genxconectados/public_html/moodle/lib/classes/component.php on line 400

Fatal error: require(): Failed opening required '/home/genxconectados/public_html/moodle/version.php' (include_path='/home/genxconectados/public_html/moodle/lib/pear:.:/opt/php56/lib/php') in /home/genxconectados/public_html/moodle/lib/classes/component.php on line 400


linea 400, es:

            require($CFG->dirroot . '/version.php');

version.php, dice:

defined('MOODLE_INTERNAL') || die();

$version  = 2017051506.00;              // 20170515      = branching date YYYYMMDD - do not modify!

                                        //         RR    = release increments - 00 in DEV branches.

                                        //           .XX = incremental changes.

$release  = '3.3.6 (Build: 20180517)'; // Human-friendly version name

$branch   = '33';                       // This version's branch.

$maturity = MATURITY_STABLE;             // This version's maturity level.


alguna idea de como proceder?


Un saludo.... 

Gracias por vuestra atención.

 
Promedio de calificaciones: -
GenXConectados
Re: Instalar moodle 3.2.2 y php 5.6.31
 

instalé Moodle 2.6.1. (ups que servicio de hosting conseguí?)


y sale ERROR:

Coding error detected, it must be fixed by a programmer: Request for an unknown renderer class core_admin_renderer

More information about this error


ALGUNA idea para SOLUCIONAR: 




 
Promedio de calificaciones: -
Imagen de Jose Luis Martin Jimenez
Re: Instalar moodle 3.2.2 y php 5.6.31
Moodlers de gran ayuda

Hola, Bernabé.

No entiendo los líos que te traes con tanto probar una versión u otra, pasando desde la última 3.5 a una que es super antigua (2.6.1 sorpresa) y sin comentar por qué motivo eliges esa precisamente y de dónde la has descargado (aquí en Moodle no está). Me da la impresión de que estás mezclando cosas de unas y otras y así me temo que no vas a llegar muy lejos.

Lo que yo te sugiero:

  1. Entérate bien cuál es la versión exacta de PHP y MySQL que tienes disponible.
    Lo mejor es usar la función phpinfo() como se comenta aquí: https://moodle.org/mod/forum/discuss.php?d=366472#p1478128
  2. Borra la carpetas moodle, moodledata y base de datos que hubieras creado antes, para pruebas anteriores.
  3. Descarga la versión más reciente de Moodle que sea compatible con tu versión de PHP y MySQL.
  4. Comienza desde cero la instalación: moodledata vacío, base de datos nueva, etc.
  5. Si te sale algún aviso o error, tranquilo. Averigua qué sucede exactamente (busca en foros, o danos todos los detalles) para corregir ese problema e intentar continuar con esa misma versión.

Y sobre todo, seguir los pasos de instalación sin saltarse nada. Instalar Moodle no es complicado, siempre que se cumplan los requisitos necesarios y se haga todo en el orden correcto.

Suerte


 
Promedio de calificaciones: -
GenXConectados
Re: Instalar moodle 3.2.2 y php 5.6.31
 

Gracias...

mil gracias...


NO tenía palabras para explicar lo que compramos como HOSTING 

1. Accedí a la compra, consultando si tenían Moodle. Dijeron ¡Si!

2. Pagué y cuando revise no tenían preinstalado.

3. Luego comencé a probar hallandome con los problems 

4. Por arte de magia pre-instalaron la versión 2.6.1  "que al final arrojó consulta con "adm de host"

5. Recibo vuestro FEEDBACK: ¡Warning: OBSOLETO! "de dónde la has descargado (aquí en Moodle no está)"

6. Estoy por adquirir otro servicio en otro proveedor (sólo quise comprar "made in")


Gracias nvte...


...la suerte ésta echada gran sonrisa (por estos casos algunos países no fueron al mundial de Russia 2018)

 
Promedio de calificaciones: -