Piazzale Italia

Aggiornare dalla versione 2.8.1 alla 3.0.10 è possibile?

 
cosimo
Aggiornare dalla versione 2.8.1 alla 3.0.10 è possibile?
 

Ciao a tutti/e,  vorrei aggiornare Moodle alla versione 3.0.10, su tre piattaforme che gestisco.

Attualmente ho queste versioni:

2.8.1+

2.8.7+

3.1.1+

Non ho fatto mai aggiornamenti e la cosa mi preoccupa un pò... pensieroso

Oltre a fare il backup fisico di tutta la cartella Moodle e del database, prima di procedere con l'aggiornamento devo aggiornare a versioni intermedie?

Praticamente per aggiornare, devo tramite ftp caricare tutti i nuovi file della versione 3.0.10 facendo sostituire quelli presenti attualmente?

Unico plugin particolare installato è il registro che vorrei continuare ad utilizzare, sapete dirmi se è compatibile anche con l'ultima versione 3.0.10 ?

Attendo qualche vostra dritta e vi ringrazio anticipatamente. ammiccante

Cosimo

 
Media dei voti:  -
Immagine Matteo Scaramuccia
Re: Aggiornare dalla versione 2.8.1 alla 3.0.10 è possibile?
Gruppo Core developersGruppo Particularly helpful MoodlersGruppo Plugin developers

Ciao Cosimo,
STF is your friend ammiccante, l'argomento dell'aggiornamento è stato trattato anche recentemente:

In generale devi darti una letta ai documenti di rilascio della versione target e vedere se ti consigliano/sono necessari step intermedi: in linea di massima è sempre meglio installare l'ultima weekly del branch corrente e poi fare il salto di aggiornamento, dopo aver valutato tutti i requisiti della target.

A che versione esattamente stai puntando per il tuo aggiornamento?
La 3.0.10 non è l'ultima e non è nemmeno più supportata (terminato l'8 Maggio: https://docs.moodle.org/dev/Releases#Version_support).

HTH,
Matteo

cosimo
Re: Aggiornare dalla versione 2.8.1 alla 3.0.10 è possibile?
 

Grazie Matteo per la risposta, come sempre rapidissima ammiccante

Ho letto un pò e francamente mi sembra un pò complicato, per le mie capacità, troppi controlli sorpreso

Mi sa che forse mi conviene rimanere con le versioni attuali, funziona tutto al top  grande sorriso

Diciamo che mi aveva spinto un pò a cambiare versione il fatto di aver letto che è uscita 'app di Moodle ma, che è compatibile solo dalla versione 3.0

Vedo un pò ok Matteo? sorridente

Nuovamente grazie e buona giornata

Cosimo

Immagine Matteo Scaramuccia
Re: Aggiornare dalla versione 2.8.1 alla 3.0.10 è possibile?
Gruppo Core developersGruppo Particularly helpful MoodlersGruppo Plugin developers

Ciao Cosimo,
se ti riferisci a Moodle Desktop, li valgono "le regole" di Moodle Mobile (v2+): la versione preferibile di Moodle è la 3.1 (https://docs.moodle.org/dev/Moodle_Mobile_Remote_add-ons).

Altrimenti, puoi consultare https://docs.moodle.org/33/en/Moodle_Mobile_features#Comparison_of_features_in_different_versions per verificare cosa sia necessario per ciascuna versione Moodle e cosa puoi coprire con il canale mobile.

Vale la pena citare anche https://docs.moodle.org/33/en/Moodle_Mobile_additional_features per tutte le versioni Moodle inferiori alla 3.2.

HTH,
Matteo