Piazzale Italia

aggiornamento moodle

 
Immagine Giacomo Pierini
aggiornamento moodle
 

Salve a tutti,

mi trovo in una situazione che sta diventando scocciante, mi ritrovo con la versione 3.2.4 di moodle e vorrei aggiornare all'ultima versione 3.3, non riesco ad aggiornare il sistema facendo così:

  • rinomino la cartella moodle in moodle_old
  • scarico il file zip, lo estraggo e carico la cartella nel server
  • trasferisco il file config.php dalla cartella rinominata alla nuova ma devo apportare tutte le modifiche dei dati 

arrivato a questo punto mi da una pagina bianca.


Ho controllato in server-> ambiente e per la versione 3.3 mi dice tutto ok a parte: 

  • unsupported_db_table_row_format --> il mio provider ha detto che non può cambiare tutto il server mysql
  • mysql_full_unicode_support--> non so cambiare il valore


il mio provider non si occupa di queste procedure che sono interamente a carico mio.


Qualcuno potrebbe aiutarmi?


 
Media dei voti:  -
Immagine Matteo Scaramuccia
Re: aggiornamento moodle
Core developersParticularly helpful MoodlersPlugin developers

Ciao Giacomo,
partiamo dal fondo: il tuo provider risponde del server MySQL che evidentemente è condiviso per cui se non può cambiarlo è inutile che ti imbarchi nell'aggiornamento ovvero cambia provider.

Per la pagina bianca è utile inserire alcune righe nel file config.php per capire cosa nasconda realmente la "pagina bianca", https://docs.moodle.org/33/en/Debugging#In_config.php cioè:

@error_reporting(E_ALL | E_STRICT);   // NOT FOR PRODUCTION SERVERS!
@ini_set('display_errors', '1');     // NOT FOR PRODUCTION SERVERS!
$CFG->debug = (E_ALL | E_STRICT);   // === DEBUG_DEVELOPER - NOT FOR PRODUCTION SERVERS!
$CFG->debugdisplay = 1;

Ho il sospetto che ci siano altri requisiti che non sono soddisfatti dall'attuale ambiente.

Un consiglio: prima di fare un aggiornamento leggere sempre i requisiti e verificare se l'attuale sistema li soddisfi, nel tuo caso: https://docs.moodle.org/dev/Moodle_3.3_release_notes#Server_requirements.

HTH,
Matteo

Immagine Giacomo Pierini
Re: aggiornamento moodle
 
Ciao Matteo, 

Mi scuso per il ritardo, controllerò al più presto! 


Grazie