General developer forum

Authentication token expiration

 
Just wondering . . .
Re: Using the app | Authentication token expiration | "Your authentication token is invalid"
Group Particularly helpful Moodlers

priscillah, did you solve this?

Using iOS app, Moodle 3.3.1  Moodle 3.3.1+ (Build: 20170817) Version 2017051501.08 Stable version, some of our students are getting these two messages(below)  I don't know the app version or iOS version, and I don'r know if it is also Andoid.

"An error occurred while updating the sites token"
&
"Your authentication token is invalid"

Still trying to sort out exactly what the circumstances are.



This from one user:

"Im not in a position to help, sorry, but fwiw, that error is a login / authentication error according to the apps language strings. 

I’ve pretty thoroughly tested the site certificate for issues for other reasons and am confident it’s not an issue with that.

It could be unsecured resources being accessed by the app. A possible test would be to create a page with a non HTTPS embedded object (e.g. an image) and see if that page causes the error"

Can anyone shed any light on this?

Any comments or suggestions?

-Derek

 
Average of ratings: -