Moodle for mobile

Error downloading file. Error downloading module files. Some files might be missing.

 
Picture of Mohammad Shafiee
Error downloading file. Error downloading module files. Some files might be missing.
 

When i build APK from github (v.3.2.1) with this instruction, I can't download files (e.g PDF) in courses and get "Error downloading file."  and get "Error downloading module files. Some files might be missing." when open pages.


 


 



 
Average of ratings: -
Picture of Mohammad Shafiee
Re: Error downloading file. Error downloading module files. Some files might be missing.
 

Official app in Google Play is OK. but the app that we compiled has error.

 
Average of ratings: -
Picture of Dani Palou
Re: Error downloading file. Error downloading module files. Some files might be missing.
Core developersMoodle HQParticularly helpful MoodlersPlugin developers

Hello Mohammad,

I guess you lack some Cordova plugin. Are you building the app using Phonegap Build or using Cordova CLI?

If you're using the CLI, please make sure you have all the cordova plugins installed (running "ionic state restore" should install them all).

Kind regards,

Dani

 
Average of ratings: -
Picture of deva m
Re: Error downloading file. Error downloading module files. Some files might be missing.
 

hi,

Even after "ionic state restore" its not getting fixed.

i had created a forum post for it, check it out

https://moodle.org/mod/forum/discuss.php?d=363702

what else to be done?



 
Average of ratings: -
Picture of Ihsan Saiful
Re: Error downloading file. Error downloading module files. Some files might be missing.
 

Hi Dani,

I have the same problem where i cannot download scorm in moodle mobile 3.4.

i build using Phonegap.  what any plugins that should be there?

Thanks,

Ihsan

 
Average of ratings: -
Picture of Juan Leyva
Re: Error downloading file. Error downloading module files. Some files might be missing.
Core developersMoodle HQParticularly helpful MoodlersPlugin developersTesters

A couple of recommendations:

- Compile using Phonegap Build

- Double check you use the same versions of the Cordova platform and Cordova plugin than us

 
Average of ratings: -