Instalación y Actualización

Problema con archivos adjuntos y migración servidor

 
Imagen de Fernando Acedo
Re: Problema con archivos adjuntos y migración servidor
Grupo Desarrolladores de pluginsGrupo Moodlers de gran ayudaGrupo Testers

Este es el soporte de Moodle. La comunidad es la que de modo totalmente altruista ofrece soporte a quien lo necesite. Es decir, todos tenemos otras tareas y en nuestro tiempo libre intentamos ayudar a los que tienen problemas o consultas.

Por lo que veo ahora revisando todo el hilo y he encontrado varios problemas por lo que posiblemente no funcione porque sea un conjunto de malas acciones que han llevado a que todo el sitio falle.


1. Como te han dicho la versión de PHP es incorrecta. Debes usar 5.6

2. La migración no esta realizada correctamente y moodledata no estaba en la ruta correcta ni con los permisos necesarios.

3. Estás utilizando una versión completamente obsoleta (2.4) y que tenia un problema relacionado con el que indicas y que se soluciono en la versión 2.5

4. El error que aparece ahora es de acceso a base de datos. Hay que configurar el acceso correctamente (evidentemente no tiene nada que ver con el otro problema)


Resumiendo, si no tienes conocimientos suficientes para realizar este tipo de tareas (moodle no es Wordpress busca a alguien que si los tenga. Una migración es una tarea sencilla que no debe tomar más tiempo del que se tarda en transferir los archivos y no ofrece habitualmente ningún problema.



 
Promedio de calificaciones:Útil (1)
Imagen de Miquel Matallanes
Re: Problema con archivos adjuntos y migración servidor
 

Hola Fernando,


Muchas gracias por tu ayuda.


Saludos,


Miquel.

 
Promedio de calificaciones: -
Imagen de Miquel Matallanes
Re: Problema con archivos adjuntos y migración servidor
 

Hola a todos!!


Muchas gracias por vuestra ayuda! por fin he solucionado el problema. Todo correcto y funcionando como debería.

Gracias por: Decirme como descargar la carpeta "moodledata" en binario y luego subir en binario.

Gracias por: La versión PHP del servidor, moodle 2.4.1 no funciona bien con php 7. (Lo he solucionado añadiendo un archivo dentro de la instalación de moodle donde se le indica al servidor que use la version php 5.6)

El mayor problema a sido importar la base de datos sin ningún error, ya que siempre superaba el tiempo de ejecución dando error 504.


He exportado la DB en bloques, hasta 6 en total, y luego los he importado uno a uno. Perfecto!!

Pendiente de: Actualizar a la ultima versión de moodle y mover la carpeta "moodledata" fuera de publico. (Solo me he limitado a migrar tal y como el cliente tenia la instalación en su servidor.)


Saludos a todos y gracias de nuevo.


Miquel.

 
Promedio de calificaciones: -