Instalación y Actualización

Problema con archivos adjuntos y migración servidor

 
www.nosolored.com - Servicios Moodle, Chamilo, Joomla y Wordpress.
Re: Problema con archivos adjuntos y migración servidor
Grupo Moodlers de gran ayuda

Buenos días:

Aparte de lo que te han comentado, hay que revisar también si la migración de Moodle se ha realizado correctamente.

Como indicas la has hecho por FTP, con este tipo de conexión la copia y subida del directorio moodledata debe realizarse con el modo de transferencia en binario para que los ficheros pdf, videos, imágenes, etc. se trasladen correctamente entre un sitio y otro. Si no se hace así te daran problemas con seguridad.

En Filezilla por ejemplo se activa en el menú Transferencia > Tipo de transferencia > Binario antes de conectarte al sitio. Descargas y luego subes también en el mismo modo binario.

Para el resto del software Moodle se puede dejar en automático cuando se copie y se traslade de sitio.

Los permisos de moodledata aunque la guía oficial Moodle comenta activarlos con 777 para carpetas o 666 para ficheros depende como tengas configurado tu entorno Linux. Moodle también funciona sin problemas con permisos estándares 755 y 644 o 700 y 600.

Saludos.

 
Promedio de calificaciones:Útil (1)
Imagen de Miquel Matallanes
Re: Problema con archivos adjuntos y migración servidor
 

Hola Jose,


Muchas gracias por tu respuesta!!

Me das una buena solución al temas de permisos, desconocía que en "binario" mantiene los permisos y archivos correctamente. 

Genial, así lo haré.


Muchas gracias por tu tiempo.


Os mantengo informados del proceso! tímido


Saludos,


Miquel.

 
Promedio de calificaciones: -
Imagen de Miquel Matallanes
Re: Problema con archivos adjuntos y migración servidor
 

Hola a todos!!


Muchas gracias por vuestra ayuda! por fin he solucionado el problema. Todo correcto y funcionando como debería.

Gracias por: Decirme como descargar la carpeta "moodledata" en binario y luego subir en binario.

Gracias por: La versión PHP del servidor, moodle 2.4.1 no funciona bien con php 7. (Lo he solucionado añadiendo un archivo dentro de la instalación de moodle donde se le indica al servidor que use la version php 5.6)

El mayor problema a sido importar la base de datos sin ningún error, ya que siempre superaba el tiempo de ejecución dando error 504.


He exportado la DB en bloques, hasta 6 en total, y luego los he importado uno a uno. Perfecto!!

Pendiente de: Actualizar a la ultima versión de moodle y mover la carpeta "moodledata" fuera de publico. (Solo me he limitado a migrar tal y como el cliente tenia la instalación en su servidor.)


Saludos a todos y gracias de nuevo.


Miquel.


 
Promedio de calificaciones: -