Installing and upgrading help

Moodle 3.2.2 fresh install - Barracuda problem

 
Picture of Peter Aherne
Moodle 3.2.2 fresh install - Barracuda problem
 

Hey Moodlers,


I've only recently begun playing with Moodle and was running it on my own shared web hosting service. I previously had various installs going (2.9 & 3.1) fine but now I'm going for a fresh install but now I'm getting these check errors:

mysql_full_unicode_support#File_format

Your database has tables using Antelope as the file format. Full UTF-8 support in MySQL and MariaDB requires the Barracuda file format. Please convert the tables to the Barracuda file format. See the documentation Administration via command line for details of a tool for converting InnoDB tables to Barracuda.

Check
mysql_full_unicode_support#Large_prefix

For full support of UTF-8 both MySQL and MariaDB require you to change your MySQL setting 'innodb_large_prefix' to 'ON'. See the documentation for further details.



From searching in the forums this seems to not be an issue unless you are using some very large courses, this is not the case for me, I'm only going to be hosting a few small courses. Is there some way I can proceed without barracuda? 

My problem is since I'm on a shared hosting service they are not willing to make the global changes required to mySQL. Do I need to install 2.9 then upgrade to 3.2.2 and ignore these issues?

Thanks,
Peter.

 
Average of ratings: -
Picture of Usman Asar
Re: Moodle 3.2.2 fresh install - Barracuda problem
Particularly helpful MoodlersPlugin developers

Peter, that use to be optional, but in newer moodle versions its a required part now, and shared hostings will NOT change their DB's just to cater one case of table format change, which is unfortunate.

So only choice you have left in case you're going to use shared hosting is use moodle 3.1.5 (not 3.1.5+)  or below - there could be possibility that upgrading from a previous version to latest wont show that issue (I have to test that).


 
Average of ratings: -
Picture of Peter Aherne
Re: Moodle 3.2.2 fresh install - Barracuda problem
 

Hi Usman,


Thanks, 3.1.5 works great. I may try to upgrade in the future but not for now.

It's seems a strange choice to make this mandatory and so make shared hosting not viable for Moodle installs anymore. I've no need or intention to upgrade to VPS hosting. If I understand correctly Barracuda is only required for particularly large courses, so often will not be required by Moodle admins so limiting the install options seems excessive.


Cheers,
Peter.

 
Average of ratings: -
Picture of Nicholas Yang
Re: Moodle 3.2.2 fresh install - Barracuda problem
 

Hi, ran into the same issue and also came across this thread in the process. My webhost confirmed they can't change the DB settings, but oddly I found that I didn't get the same error when installing on my live server -- only on my local XAMPP site.

Many installs later, I discovered that using database collation utf8_general_ci instead of utf8mb4_unicode_ci seems to bypass this error and allow the install to proceed. The error no longer shows on install but still appears after the install is complete, as an amber "Check" on the Server > Environment page. I think for my purposes (also a small site), utf8_general_ci seems sufficient enough.

 
Average of ratings: Useful (1)
Picture of Ken Task
Re: Moodle 3.2.2 fresh install - Barracuda problem
Particularly helpful Moodlers

@Nicolas ... thanks for sharing ....

Funny you should mention this!  Have been involved recently in upgrading multiple moodles ... after upgrading, got the new componet check (environment.xml) and checked.   Hmmm ... no mention of utf8mb4 ... which, as I understand it, is really for the new 'mojis' - see, I keep so up to date that I don't know how to spell it! smile

So, is thats what makes online learning better ... more modern?    Uhhhh ... hadn't seen that research yet (don't think I will either).

I do hope, that now that's been discovered, that one is not subjected to forced use (ieg, it gets 'fixed').

'spirit of sharing', Ken


 
Average of ratings: Useful (2)
Picture of Sonny Herrick
Re: Moodle 3.2.2 fresh install - Barracuda problem
 

I added a new noodle instance 3.3+ and created a new database imported the sql file from my old site and ran the command line script to convert from antelope to barracuda but still am unable to clear this error and get past this point in setup? ----- (For full support of UTF-8 both MySQL and MariaDB require you to change your MySQL setting 'innodb_large_prefix' to 'ON'. See the documentation for further details. ) 

I am running on iis  windows server 2012. 

Using phpMyAdmin and have changed coalitions with no answer.


TY  

  

 
Average of ratings: -
Picture of zizo zizo
Re: Moodle 3.2.2 fresh install - Barracuda problem
 

Dear ,

I tried this version Moodle 3.1.5 (Build: 20170313)  as you said  and same problem 

mysql_full_unicode_support#File_format

mysql_full_unicode_support#Large_prefix


Thanks


 
Average of ratings: -
Picture of Lukas Lukas
Re: Moodle 3.2.2 fresh install - Barracuda problem
 

Same here. Any other idea? Maybe another build of this version?



Screenshot

 
Average of ratings: -
Picture of Ambrish Tiwari
Re: Moodle 3.2.2 fresh install - Barracuda problem
 

Hello Peter 

If you use XAMPP server so, you can add. Go to XAMPP server. 

click on Config-> my.ini then open new text file. In this text file, you copy this contain below and paste. I hope resolve your issue. 


[client] 

default-character-set = utf8mb4


[mysqld]

innodb_file_format = Barracuda 

innodb_file_per_table = 1 

innodb_large_prefix  


character-set-server = utf8mb4

collation-server = utf8mb4_unicode_ci 

skip-character-set-client-handshake 


[mysql

default-character-set = utf8mb4  


 
Average of ratings: -
Picture of Cyril Zufferey
Re: Moodle 3.2.2 fresh install - Barracuda problem
 

Thanks for your helpfull answer, Ambrish Tiwari.

 
Average of ratings: -
Picture of Lee Hensley
Re: Moodle 3.2.2 fresh install - Barracuda problem
 

So just my two cents here, I am Running moodle 3.3 on a shared host with rather large courses. I have not had a problem but did the upgrade not the fresh install. My suggestion for you to install 3.2 then upgrade from that. also you need to be sure to change the config.php to utf8 before install otherwise this error will stop your install. Not sure if you can do that after upload and extract on the server, but before you load it in the browser on a fresh install. I also was going to upgrade to 3.4 but the php version is a problem. but that is for another topic. 

 
Average of ratings: -