Moodle announcements

URGENT: Please upgrade your Moodle site to the latest stable version

 
Martin Dougiamas
URGENT: Please upgrade your Moodle site to the latest stable version
 

It’s come to our attention that administrators of some Moodle sites may have missed out on our usual announcements about important fixes in our most recent stable releases.

Stable point releases Moodle 3.2.2, 3.1.5, 3.0.9 and 2.7.19 were released as per our usual two-monthly schedule on Monday, 13 March 2017.

Among the improvements there are very important security fixes for serious problems which may allow users to gain privileges or change data improperly.

We strongly recommend you upgrade your Moodle site to one of the most recent stable versions as soon as you can.  Since these stable releases only fix bugs and don’t introduce new features there should be no disruption to your production sites (so please don’t put it off!).

To get the very earliest notification of these issues in future via direct email please make sure you REGISTER your site, using the Registration link in your Site Administration pages in your own Moodle site.

The same notifications are posted publicly a week later in our Security Announcements forum and in the release notes.

If you are having any trouble upgrading your site on your own please contact a Moodle Partner near you or reach out to us at Moodle HQ and we’ll be happy to find someone to help you.

Note:  If you are using our MoodleCloud service you don’t ever need to worry about these: MoodleCloud sites are always running the most recent versions of Moodle.