Cosas de Administradores

Tema estable para V-3.2

 
Imagen de Fernando Acedo
Re: Tema estable para V-3.2
Grupo Desarrolladores de pluginsGrupo Moodlers de gran ayudaGrupo Testers

Hay una discusión abierta en el foro de temas, en inglés, donde se está comentando el futuro de los temas actuales. El hilo en cuestión fue abierto por mi compañero Jeremy porque queriamos saber como iba a ser el futuro de Boostrapbase, el tema base usado para la mayoria de temas y que moodle parece haber abandonado.

Este es el enlace: https://moodle.org/mod/forum/discuss.php?d=348711

El principal problema con Boost es la poca estabilidad de su base. Moodle ha pasado de Bootstrap 2 a la versión 4. Pero lo peor no es eso sino que la versión 4 está en Alpha, es decir en un nivel previo a Beta, la versión de pruebas.

Asi que lo que se decidió fue lanzar un sistema nuevo de temas basado en algo que todavia esta en desarrollo (y bastante atrasado), y además, ese tema se utiliza por defecto al instalar moodle 3.2.

Como podrás leer, algunos desarrolladores opinamos que el paso fue demasiado atrevido y, en mi opinión, arriesgado. Hay que pensar que se generan unas 5 incidencias diarias y el cambio de Alpha 5 a 6 genero cientos. Asi que no sabemos cuando se publicará la versión de Bootstrap 4 estable y, una vez publicada, moodle deberá modificar Boost para que funcione correctamente con los cientos de cambios realizados.

Si a todo ese problema le añadimos los cambios generales en 3.2, como la mensajeria y cambios en librerias, tenemos una versión 3.2 con un tema por defecto inestable y con el resto de temas con problemas varios.

Yo solo te puedo comentar sobre Adaptable. Hay varios problemas que estamos solucionando y en breve publicaremos una versión. La actual es estable pero hay algún problema pendiente de resolver, como la mensajería.

Mi consejo es, si quieres una versión estable, seguir con moodle 3.1 y cualquier tema disponible para dicha versión. En unas semanas aparecerán versiones más estables de temas para 3.2 y entonces se podrá usar moodle 3.2 con más garantias.

 
Promedio de calificaciones:Útil (1)
Imagen de José Díaz
Re: Tema estable para V-3.2
 
Gracias Fernando, excelente la aclaratoria. 


Mayor sorpresa cuando leí lo de la inestabilidad, si no es por investigar el tema  child basado en Boost y la alerta de Mary Evans, no me entero del riesgo que lo confirmas con detalles. Como dices el tema por defecto de v3.2 y de paso la demo lo usa... 


Para la v- 3.1 y tema Adaptable versión Bootsrap  2.3.2.  

Tremendo trabajo tienen por delante.  Éxito con Adaptable y la 3.2 .


Aquí el demo de Adaptable  https://adaptable.ws/demo/

 



 
Promedio de calificaciones: -