General plugins

Error with Flashcard module

 
Picture of Juan Ezeiza
Error with Flashcard module
Particularly helpful Moodlers

Hi everybody,

When I try to import something or backup one of my courses I get a white screen. If I turn the debugger on, I obtain this message:

Fatal error: Class backup_flashcard_activity_task contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (backup_activity_task::define_my_settings) in /var/www/html/moodle/mod/flashcard/backup/moodle2/backup_flashcard_activity_task.class.php on line 55

I'm running a Moodle 3.1.4+ in a Debian 8.1 server, php 5.6.30 and mysql 5.5.54.

Any suggestion would be welcome.

Thank you.
 
Average of ratings: -
Picture of Emma Richardson
Re: Error with Flashcard module
Documentation writersParticularly helpful MoodlersPlugin developers

An issue with the plugin - I would try contacting the developer.

 
Average of ratings: Useful (1)
Picture of Juan Ezeiza
Er: Re: Error with Flashcard module
Particularly helpful Moodlers

Thank you, Emma.

 
Average of ratings: -
Picture of Juan Ezeiza
Er: Re: Error with Flashcard module
Particularly helpful Moodlers

Since I couldn't make backups, import or export contents, or even delete a course, I've made a downgrade of the flashcard module. Now everything works fine. I'll wait for a new release.

Thanks anyway.

 
Average of ratings: -
Picture of Eva Adam
Re: Er: Re: Error with Flashcard module
 

Dear Juan,

I have similar problems with the flashcard module but it seems I cannot simply downgrade. Could you please let me know how to do this?

Thank you,

Éva

 
Average of ratings: -
Picture of Juan Ezeiza
Er: Re: Er: Re: Error with Flashcard module
Particularly helpful Moodlers

Hi Eva,

You are right. You cannot simply downgrade. It's a bit tricky.

You have to put the old version of the flashcard module in the "\mod\flashcard" folder of your Moodle instalation and change the version to a higher one. To do it, edit the file "version.php" and change the strings that contain the version number. For example, I changed them in this way:

$plugin->version  = 2017022202;
...
$plugin->release = '3.1.0 (Build 2017022202)';

When you're done, go to "site administration\Notifications" and you'll be asked to "upgrade" the flashcard module, but in fact you'll "trick" your Moodle to downgrade it.

Good luck!

 
Average of ratings: Useful (1)
Picture of Eva Adam
Re: Er: Re: Er: Re: Error with Flashcard module
 

Hi Juan,

Thank you for the info! Yes, it is tricky indeed.

In the meantime I have found a fix on github (https://github.com/vfremaux/moodle-mod_flashcard) and replaced the flashcard folder content with the new one and now everything seems to be working again. The only thing I still don't quite understand is that I originally updated the module via the web on 12 March and the update that I copied from github to the server today was dated 2 March... Nevertheless, I am happy that now this problem has been solved on our server. And I hope that I will not need this version trick in the future smile

Bests,

Éva

 
Average of ratings: -
Picture of Juan Ezeiza
Er: Re: Er: Re: Er: Re: Error with Flashcard module
Particularly helpful Moodlers

Jó reggelt, Éva.

The fix on github works fine! I'm happy because I wanted to try the new features of the flashcard module.

Köszönöm,


Juan

 
Average of ratings: -