Problemas Generales

Usuarios y contraseñas no funcionan al instalar copia de Moodle del hosting en mi pc

 
Imagen de Miguel Fabo
Usuarios y contraseñas no funcionan al instalar copia de Moodle del hosting en mi pc
 

Buenas noches a todos, queridos amigos. Quisiera consultarles lo siguiente, a ver si a alguien se le ocurre una solución.
Estoy migrando mi Moodle de un hosting a otro aprovechando que se me venció el contrato con el primero (el motivo es que el hosting que vengo usando usa versiones muy viejas de php y mysql y se volvió inseguro e inestable).
Hice backup de todo (carpeta moodle, moodledata, base de datos). Así que ahora quisiera instalar el mismo Moodle que vengo usando en mi computadora (como para tener de referencia los contenidos y estructura de los cursos, etc e ir copiando todo al nuevo servidor).
La página se ve igualita a la original, pero el problema comienza al querer iniciar mi sesión con usuario y contraseña, porque Moodle ya no reconoce mis datos de acceso. Es muy raro, porque copié todo tal cual estaba en mi hosting, descargué todo en un archivo ZIP.

Ahora estoy utilizando Wamp, y adapté las rutas de los directorios y archivos para Windows en el archivo config.php, pero no hay caso. Sé que a veces en estos procesos pueden "romperse" los archivos adjuntos, etc, pero yo solo necesito poder acceder al contenido de mis cursos. A alguien se le ocurre qué puede estar pasando? Les adjunto mi config.php para que vean si descubren algo:

<?php  // Moodle configuration file

unset($CFG);
global $CFG;
$CFG = new stdClass();

$CFG->dbtype    = 'mysqli';
$CFG->dblibrary = 'native';
$CFG->dbhost    = 'localhost';
$CFG->dbname    = '*******';
$CFG->dbuser    = '*******';
$CFG->dbpass    = '*******';
$CFG->prefix    = 'mdl_';
$CFG->dboptions = array (
  'dbpersist' => 0,
  'dbport' => '',
  'dbsocket' => '',
);

$CFG->wwwroot   = 'http://localhost:81/*****/moodle';
$CFG->dirroot   = 'D:\Wampee-2.1-beta-2\www\*******\moodle';
$CFG->dataroot  = 'D:\Wampee-2.1-beta-2\moodledata';
$CFG->admin     = 'nnnnnnnnn';

$CFG->directorypermissions = 0777;

$CFG->passwordsaltmain = 'Obviamente no puedo compartirlo';

require_once(dirname(__FILE__) . '/lib/setup.php');

// There is no php closing tag in this file,
// it is intentional because it prevents trailing whitespace problems!


Aclaro que la versión de Moodle en cuestión es la 2.6.11, estoy corriendo php 5.3.29 y MySQL 5.1.68 Desde ya, muchas gracias por cualquier consejo o sugerencia!

 
Promedio de calificaciones: -