Cosas de Administradores

Actualizar Moodle 2.9.9

 
MarcosSL
Actualizar Moodle 2.9.9
 
Buen día con tod@s...

Les comento que tengo una plataforma en producción con Moodle 2.9.9 y deseo actualizarla a una versión 3.x, ya que no hay más soporte para la 2.9.9

Entonces, me gustaría tener referencias o recomendaciones de cual versión es mejor actualizar, es decir: Moodle 3.2, 3.1 o la 3.0.

También comentar que la plataforma actual, no tiene ningún plugin adicional instalado, y el theme está en base a un Afterburner que personalicé y renombré con otro nombre. 

Así mismo tengo una advertencia en la comprobación del servidor:
"unsupported_db_table_row_format: Su base de datos tiene tablas utilizando el formato de fichero Antelope..."
no se si esto podría ser un problema para la actualización.

Saludos y gracias por sus recomendaciones.

Marcos.

 
Promedio de calificaciones: -
Imagen de Eduardo Hm
Re: Actualizar Moodle 2.9.9
 

Buenos días,


Si vas a realizar un cambio de versión grande, lo mas recomedanble es irte a la última versión estable disponible para entorno de PRODUCCION, en este caso la última versión disponible es la 3.2.1.


En donde trabajo, se ha optado por seguir actualizando en la versión que tenga mas tiempo de soporte de seguridad, y en este caso, hemos decidido de permanecer en la 3.1.x, que tiene soporte LTS mas alla de enero del 2019, mientras que la versión 3.2.x tiene soporte de seguridad hasta noviembre del 2018.

En cuanto al problema que tienes en la comprobación del servidor, creo que los tiros pueden ir por aquí. Leete este post en donde te explican cómo poder solucionar esas tablas.

https://moodle.org/mod/forum/discuss.php?d=314802&parent=1260935


Saludos



https://moodle.org/mod/forum/discuss.php?d=314802&parent=1260935

 
Promedio de calificaciones:Útil (1)
MarcosSL
Re: Actualizar Moodle 2.9.9
 
Gracias por tus comentarios Eduardo,

Veo conveniente entonces actualizar a la versión 3.1, ya que veo que tiene soporte hasta mayo de 2019.

En este caso, ves recomendable actualizar primero a la 3.0 y luego a la 3.1 o no habría problema hacerlo directamente a la 3.1

Ahora revisaré el link que me enviaste.

Saludos y gracias nuevamente.

 
Promedio de calificaciones: -
Imagen de Héctor Noel González García
Re: Actualizar Moodle 2.9.9
 

Estimado Marco, te saludo con gusto.

Marco, es verdad que la versión de Moodle 3.1 tendrá un soporte mayor en relación a tiempo, sin embargo, te comparto que yo tengo instalado Moodle en sus versiones 3.1 y  3.2+ en portales en producción y la versión de Moodle 3.1 tiene bastantes detalles en su funcionamiento cotidiano, detalles que han sido corregidos en Moodle 3.2+. En mi experiencia te recomiendo la versión que te presente menos problemas con el usuario final en este caso Moodle 3.2+.

Saludos... 

 
Promedio de calificaciones:Útil (1)
MarcosSL
Re: Actualizar Moodle 2.9.9
 

Gracias por tus apreciaciones Héctor,

Lo tendré en cuenta, lo primero que haré es actualizar a la 3.1 y luego de un tiempo si no surgen inconvenientes actualizar a la 3.2.

Muchos saludos.


 
Promedio de calificaciones: -
Imagen de Eduardo Hm
Re: Actualizar Moodle 2.9.9
 

Buenas de nuevo,


Sea cual sea a la versión a la que vayas a actualizar, puedes hacerlo directamente desde la versión 2.9.x. Hace unos años pase de la versión 2.4 a la versión 2.9 sin problemas. De momento se puede realizar ese tipo de actualizaciones de version para los Moodle 2.x y 3.x. Si tienes Moodle muy obsoletos de la versión 1.9.x, si hay que hacerlo en dos pasos.


Suerte!!! ;)

 
Promedio de calificaciones:Útil (1)
MarcosSL
Re: Actualizar Moodle 2.9.9
 

Entendido Eduardo,

Gracias por tu respuesta.

Saludos.

 
Promedio de calificaciones: -