Security announcements

MSA-16-0023: Question engine allows access to files that should not be available

 
Picture of Marina Glancy
MSA-16-0023: Question engine allows access to files that should not be available
 
Description: User can guess URL of the file embedded in a question that they are not able to access and download it using identificator of a question they can access
Issue summary: Question engine allows access to files that I should not be able to view
Severity/Risk: Minor
Versions affected: 3.1 to 3.1.2, 3.0 to 3.0.6, 2.9 to 2.9.8, 2.8 to 2.8.12, 2.7 to 2.7.16 and earlier unsupported versions
Versions fixed: 3.1.3, 3.0.7, 2.9.9 and 2.7.17
Reported by: Martin Gauk
Issue no.: MDL-53744
CVE identifier: CVE-2016-8642
Changes (master): http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-53744