Future major features

3.2 new required minimum PHP version

 
Randy Thornton
3.2 new required minimum PHP version
Group Documentation writersGroup Particularly helpful Moodlers


I notice on the dev page for upcoming 3.2 release that the required minimum for PHP is listed as 5.6.5.

Is this correct and is this for all platforms?

As this would be a jump for some people who are still sitting on 5.5, it would be a good idea to publicize that a bit. The minimum is currently 5.4.4 and has been since 2.7.


 
Average of ratings: -
Picture of Dave Balch
Re: 3.2 new required minimum PHP version
Group Core developersGroup Particularly helpful MoodlersGroup Plugin developers

Yup, 5.6 - take a look at https://tracker.moodle.org/browse/MDL-53019

I'm pretty sure it'll be included in the release notes, when the release happens.

 
Average of ratings: -
Randy Thornton
Re: 3.2 new required minimum PHP version
Group Documentation writersGroup Particularly helpful Moodlers

Thanks Dave. Makes sense, I just need to get the word out to a few people who self host about it.

 
Average of ratings: -
Picture of Fernando Oliveira
Re: 3.2 new required minimum PHP version
Group Plugin developers

Well, I'm running Moodle 3.1 with PHP 5.6.29 and when I run the Server Check tool to check for compatibility with Moodle 3.2, it gives me a green light. Here's a screenshot: http://www.screencast.com/t/vqCfoYLaCj

Unless I've got the semantic versioning thing all messed up in my head, I'm pretty sure that 5.6.26 is less than 5.6.5.

I assume this is a bug? 




 
Average of ratings: -
Picture of Eric Merrill
Re: 3.2 new required minimum PHP version
Group Core developersGroup Particularly helpful MoodlersGroup Plugin developers

Numbers only break with periods. So 5.6.26 is greater than 5.6.5, because:

5 = 5

6 = 6

26 > 5

Hope that makes sense.

 
Average of ratings: -
Picture of Fernando Oliveira
Re: 3.2 new required minimum PHP version
Group Plugin developers

Sure does, Eric. Thanks.


BTW: Hope to see you again at the next Canadian Moot!

 
Average of ratings: Useful (1)
Randy Thornton
Re: 3.2 new required minimum PHP version
Group Documentation writersGroup Particularly helpful Moodlers


29 > 5, in PHP versioning.

5.6.29 is the latest 5 series version. 5.6.5 came out almost two years ago. Release notes and details are here: http://php.net/ChangeLog-5.php



 
Average of ratings: -