General help

Exabis ePorfolio block only Showing for Admin

 
Picture of Dr. Nellie Deutsch
Exabis ePorfolio block only Showing for Admin
 

Hi,

I need help with Exabis ePorfolio block on two of my Moodle 2.9 and 3.1 sites. The block is only showing for admin not for anyone else and I fixed permissions.

Thank you. 


 
Average of ratings: -
Picture of Ralf Hilgenstock
Re: Exabis ePorfolio block only Showing for Admin
Core developersParticularly helpful MoodlersTranslators

Hi Nelly,

maybe you should add the permissions to student and teacher role first

Ralf

 
Average of ratings: -
Picture of Dr. Nellie Deutsch
Re: Exabis ePorfolio block only Showing for Admin
 

Hi Ralf,

According to the developers of the plugin, there is no need to give anyone permissions of any kind. They are looking into it. I'll update you once I know what's going on. 

Thank you.

 
Average of ratings: -
Picture of Dr. Nellie Deutsch
Re: Exabis ePorfolio block only Showing for Admin
 

The developers of Exabis ePortfolio found the solution "exaport:use" was disabled in permissions for authenticated user. 

I hope this helps others. 

Thank you to the developers who provided qualify support. 

 
Average of ratings: -
Picture of Blair F.
Re: Exabis ePorfolio block only Showing for Admin
 

For the record, it seems that Exabis allows access for Authenticated User to a bunch of things and one of them leads to an error on the Security Overview, stating, "The default user role 'Authenticated user' is incorrectly defined!"  I found that changing the exaport:import from Allow to Not set removes the warning. 



 
Average of ratings: -