Security announcements

MSA-16-0022: Web service tokens should be invalidated when the user password is changed or forced to be changed

 
Picture of Marina Glancy
MSA-16-0022: Web service tokens should be invalidated when the user password is changed or forced to be changed
 
Description: Access to mobile app using the old web service token should be revoked if the user changes the password
Issue summary: Users tokens should be invalidated when the user password is changed (or forced to)
Severity/Risk: Minor
Versions affected: 3.1 to 3.1.1, 3.0 to 3.0.5, 2.9 to 2.9.7, 2.8 to 2.8.12, 2.7 to 2.7.15 and earlier unsupported versions
Versions fixed: 3.1.2, 3.0.6, 2.9.8 and 2.7.16
Reported by: Juan Leyva
Issue no.: MDL-49026
CVE identifier: CVE-2016-7038
Changes (master): http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-49026